Repl for fcc-medical-data-visualizer not running, shows Package operation failed

Tell us what’s happening:

my solution isn’t running.

This is the output Updating package configuration

--> python3 -m poetry lock

The Poetry configuration is invalid:
  - 'description' is a required property

exit status 1

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.2 Safari/605.1.15.

Challenge: Medical Data Visualizer

Link to the challenge:

I got this same error. Delete the the poetry.lock file and pyproject.toml file.

next click on the packages tab, This is the cube pic on the left side bar.

then install all the imports you need such as pandas, seaborn and numpy.


thanks for the help!

Hi @SupremeSadat It does not allow me to install the packages and shows SyntaxError: invalid syntax for !pip install -q or pip install or anything like that. I also tried installing the pip itself by using the code python -m ensurepip --default-pip still the same problem. I appreciate your help

If you trying to install packages of webiste, then you have to use the package selector on the left side. if you trying to install pip on you computer, the best thing to do is look up a tutorial on youtube on how to install pip. you use pip install inside the windows console. might need to used pip3 install. could you post a screen shot showing the problem. thanks

1 Like

Thanks @SupremeSadat .The packages on the left side worked fine. I thought maybe I can use pip on the same as you can use it on colab.

The ‘description’ property is missing in pyproject.toml file and issue will resolve if you add description = “” in pyproject.toml file.

1 Like