Replit issue at Medical Data Visualizer boilerplate

Hi. I’m currently working on the third Data Analysis certification project and I came across this problem at Replit. What can I do?

Thanks in advance.

Replit: Package operation failed.

Replit: Updating package configuration

→ python3 -m poetry add matplotlib numpy
Using version ^3.6.0 for matplotlib
Using version ^1.23.3 for numpy

Updating dependencies
Resolving dependencies…

SolverProblemError

The current project’s Python requirement (>=3.7,<4.0) is not compatible with some of the required packages Python requirement:
- numpy requires Python >=3.8, so it will not be satisfied for Python >=3.7,<3.8

Because no versions of numpy match >1.23.3,<2.0.0
and numpy (1.23.3) requires Python >=3.8, numpy is forbidden.
So, because root depends on numpy (^1.23.3), version solving failed.

at venv/lib/python3.8/site-packages/poetry/puzzle/solver.py:241 in _solve
237│ packages = result.packages
238│ except OverrideNeeded as e:
239│ return self.solve_in_compatibility_mode(e.overrides, use_latest=use_latest)
240│ except SolveFailure as e:
→ 241│ raise SolverProblemError(e)
242│
243│ results = dict(
244│ depth_first_search(
245│ PackageNode(self._package, packages), aggregate_package_nodes

• Check your dependencies Python requirement: The Python requirement can be specified via the python or markers properties

For numpy, a possible solution would be to set the `python` property to ">=3.8,<4.0"

https://python-poetry.org/docs/dependency-specification/#python-restricted-dependencies,
https://python-poetry.org/docs/dependency-specification/#using-environment-markers

exit status 1

Replit: Package operation failed.

1 Like

I think I solved.

At pyproject.toml file, I changed the python value within [tool.poetry.dependencies] to “>=3.8,<4.0” and it worked.

Feel free to response, tho. I’m pretty new to this and any feedback would be truly appreciated.

1 Like

Quick follow up:

I updated all packages to their current versions.

As of October 17th:

[tool.poetry.dependencies]
pandas = “>=1.5.0”
python = “>=3.8”
seaborn = “>=0.12.0”
matplotlib = “>=3.6.1”
numpy = “>=1.23.4”