Run Functional Tests Using a Headless Browser and Run Functional Tests Using a Headless Browser II

so using replit seems the only way to submit the certificate projects?
can you give a link or something on how to use glitch to setup for the certificate projects?

Import the boilerplate from GitHub

Make sure you run enable-npm in the terminal.

1 Like

i can not pass this two tests with the same code i have passed using locally:-

// running tests
If the number is invalid, returned will be 'invalid number'.
If both the unit and number are invalid, returned will be 'invalid number and unit'.
// tests completed

here is the link:-

seems like glitch is removing the extra forward slash(/) from the route when FCC test my there any way to fix this?

I am facing same problem.
Did you passed the test?

which problem are you facing?

test are passing here

FCC test shows error

here response from my live app

I have also tried it locally but same thing happens there too.

Try to use this( instead of localhost and you should not stop the server while running the tests in FCC while your code is locally.what browser are you using and what editor for the local?

here is my github repo

i am using vscode editor

you should be using chrome to run the FCC tests,and as i said use = ''; and uncomment out everything including and most importantly this.timeout(5000); and it will work.look the screenshoots below.

Thank you. It worked :slight_smile:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.