Run Test Suite to See Unit Tests!

I created the Product Landing Page and am trying to test it with the Fork Me! tester but when I run it, it doesn’t tell me if it passed or failed and just says “Load Tests”, when I click that it says “Run Test Suite to See Unit Tests!”. Any idea what that means or how I can test it?

Have you been able to run the tests against your other projects?
Can you post a link to your pen?

Hi, Yes I have been able to run the tests on my other projects. This is the first time I’m doing it on my Macbook Pro but that shouldn’t matter I wouldn’t think.

You’re right, it shouldn’t make a difference but it’s good to know you’re trying it for the first time on a new computer. There may be a setting you don’t have right.
What browser are you using? There are known issues with the tests when using Safari.
What version of MacOS are you running?
Are you able to run the tests against your previous projects on your Mac?

Edit: I’m asking all this because I was able to run the tests against your pen using Chrome on my MacBook Pro. I also tried with Safari and was successful there too. I’m running Mojave with the latest versions of Chrome, Firefox & Safari.

I have Catalina but I was using Brave. Maybe thats why

So you’ve tried with another browser and it’s working?

I know there’s issues with ad-blockers not letting some tests pass when doing the lessons. I’m not aware of issues with the tests for the projects but that’s probably because users have turned off the ad-blockers by the time they get to the projects.

Does it work if you just add the script to the page? Click the Settings button, go to the JS section, paste in the test script in one of the bottom boxes.

test script:

You are passing 14 out of 16 tests for the Product Launch Page you linked to.

For test 6 you have to add id="video" to the video iframe.

For Layout test 1, I don’t think you can pass that test and keep your current design. The header (or a child element) should be using position: fixed and be at the top of the page. It won’t work with the #nav-bar because it is inside the .logo div element. If you move it out and up before that element you can set it on #nav-bar as well.

#header {
  position: fixed;
  width: 100%;
  top: 0;

Thanks I tried it with Chrome and it worked fine. I added the id=“video”. I will change the header position and try again.
Thanks for Your Help.

Good to know things are working for you