Running the Relational Database Curriculum in your Browser

The web based version of the Relational Database curriculum is here! Follow the steps below to run the courses in your browser. If you want to run them locally instead, you can learn how here. Note: you cannot earn your certification running these locally.

How to get started

Follow these steps to get started with the browser version of the courses:

  1. First, you will need to create a GitHub account if don’t have one
    If you don’t want to save your progress, you can skip to step 4 after you have a GitHub account
    Note: You cannot earn your certification without saving your progress
  2. After that, go to http://freecodecamp.org/learn/relational-database/
  3. To save your progress on freeCodeCamp.org, you will need to be signed in. Click the sign in button at the top right and sign in if you aren’t already
  4. Go to http://freecodecamp.org/learn/relational-database/
  5. Click on one of the courses to go to the course page
  6. Find and click the button to “start the course”
  7. Click “Run With CodeAlly” when the button appears
  8. You will need to sign in to CodeAlly using your GitHub account. This will redirect you away from the page. After you’re signed in there, repeat steps 4-7. You will only need to do this once. Running subsequent courses will not redirect you away from the page.
    Note: You must have third party cookies enabled to log in to CodeAlly to run the course.

From there, it may take a few moments, but the tutorial should start automatically. It will load a virtual machine with VS Code running and launch the CodeRoad extension, which will start the tutorial. Follow the instructions in CodeRoad to go through it. If you get stuck at any point, see the troubleshooting steps below.



Troubleshooting

If you’re stuck in some way, continue reading to learn how to troubleshoot some of the issues we’ve seen…


Issues with starting a course:

Nothing happened when I clicked start

If you see a blank white screen with only the freeCodeCamp navbar or you are stuck in a loop of trying to login to CodeAlly, you likely need to enable third-party cookies. Enable them and try again. Some browser extensions can block cookies as well, so you may need to disable the extension or adjust settings in there.

You are stuck on the last step of ‘Loading remote environment’

Screen Shot 2022-01-24 at 2.37.32 PM

It shouldn’t take more than a minute or so to go through the steps above. If it seems stuck on the last step, refresh the page and start the project again. It may then finish the loading process.

If you have a VPN, you can try disabling it:

If that doesn’t work you can try this – start the project in one tab and let it try to load for a minute. Then, open another tab (don’t close first one) and start that same project in the new tab.

If none of these work, there may be a bigger issue and you likely won’t be able to start the course right now. Create a forum post and let us know.

Your container loaded, but CodeRoad didn’t start automatically

If CodeRoad didn’t load automatically, open the command palette and start the extension manually:
Mar-09-2022 20-44-44

CodeRoad started, but it’s blank and didn’t load the course

If CodeRoad loaded but your course didn’t start, close the CodeRoad tab and manually reopen it, as shown above. Repeat until it loads your course.

Your container loaded, but the terminal is not visible

To open the terminal, click on the hamburger menu on the upper left corner > Terminal > New Terminal.


Issues within a course:

Stuck on a step

There’s various issues that make it so you might not be able pass or run a step. The first thing you should try is using the reset button on CodeRoad. That will reset your progress to the beginning of the step you are on - you will have to do the step again. If that doesn’t work, try exiting the terminal by typing exit into it, and opening a new one.


Issues with your progress getting saved:

You finished a course but don’t see check mark next to it when going back to your freeCodeCamp account

Refresh the page to see if that works. A page refresh is required before you see the check mark.

The checkmark still didn’t show up

After the last step of a course, you will see a ‘continue’ button to finish it:
Screen Shot 2022-03-09 at 8.52.28 PM

Clicking ‘continue’ is what triggers your progress to get saved. There’s a chance you didn’t click it or something went wrong. Open your finished course back up and it should take you to that screen. Click the continue button again to save your progress to your freeCodeCamp account.

Still no check mark? Recycle the VM

Your user token is used to save your progress. As a security measure, we delete them when you sign out of freeCodeCamp. A new token is created again when you open up one of the projects, but existing VM’s still have the old token until it shuts itself down. Open up a different project to shut down your running VM. Then go open the old project back up; the container should now have your new token. If you finished the project, it should take you right to the screen in the image above. Press that continue button to submit the project again. If this is the issue, it should now be saved and show up the next time you refresh your freeCodeCamp page.


How to save your files for certification projects

When you complete one of the certification projects, you will be asked to save your files somewhere and submit a link to them on freeCodeCamp. Each project has instructions how to create the files and what files you need to save and submit.

In the image above, the file explorer is the left panel with the universe.sql file in it. If you don’t see this panel, click the icon on the far left that looks like two pieces of paper to open it. It’s the one highlighted in white. Once the panel is open, click on a file to open it in the main editor and see the contents of the file. Select all of the contents and copy them. Create a file on your computer with the same name as the file you copied and paste the contents into it. Upload your file(s) somewhere public and submit the URL to them on freeCodeCamp.


Other issues:

You are stuck in some other way

Create a new topic on the forum and someone can help you troubleshoot the problem


Last resort:

If all else fails, you can delete your container and start over

As a last resort, you can go to your CodeAlly dashboard and delete the container with the name of the tutorial that is problematic. Unfortunately, you will have to start the tutorial from the beginning if you do this. Note: the dashboard may not update until you refresh the page.

41 Likes

I believe that my database is but it won’t let me pass, with the run feedback saying:

“characters” should have the correct rows for “Daisy” and “Yoshi”

Any hints for me, or is there a mistake in the tests?

3 Likes

Daisy’s color should have been Yellow @mrsimonsen? FYI, you be able to use that reset button to get to the beginning of the step you are on.

Edit: That looks correct @mrsimonsen. The run feedback isn’t for that step, it’s for one of the steps right before that step. Sometimes the tests get misaligned with the instructions - I’m not sure why, I’ll investigate further. I try to walk a few people through getting them realigned here

2 Likes

The step was to change Daisy’s color from Yellow to Orange. I’ve done the reset - which resets back to the start of the previous step - where I need to add Daisy and Yoshi.

1 Like

Were you able to get back on track after using the reset?

Also, are you running this on freeCodeCamp or locally?

2 Likes

Running through freeCodeCamp. Yesterday I reset twice and redid the previous and current step to have it still not pass.

1 Like

This did the trick. I edited the test directly in vim to I didn’t have to deal with the whole hiding part.

It was test 670 that wasn’t getting commented out. Thanks for your help!

2 Likes

The ls -1 command test in the tutorial isn’t passing even though it’s listing as it should. Any help would be appreciated.

3 Likes

That’s an l (el), not a 1 (one) @Stryife. Try it again with the el.

4 Likes

that worked thank you

4 Likes

Facing problem in this course. Accidentally closed the tutorial tab in the “Learning Bash” course, now can’t reopen it.
Also if I am stuck in a tutorial, giving the correct answer doesn’t complete it.
Edit: reopened the tutorial. Now the problem is passing the test.
the test is " Wait. You don’t need to recreate them. You can just move the other images here. Go back to the website folder from here. It’s three folder back."
I am currently in the website folder still doesn’t pass.

4 Likes

Check the hints in that step @tanjimanim007 - they should tell you how to pass it. If you are still facing problems, let us know.

1 Like

Yes that worked thanks.

3 Likes

Having a problem with the mario database

2 Likes

That looks like the command to display the databases, it’s asking to display the tables @Stryife.

1 Like

Weird because in the hints it even says use the list command but that worked

2 Likes

Thanks for reporting - I will get that fixed :+1:

2 Likes

I have finished the “Build a Celestial Bodies Database” project, I tried to upload my github repo to finish the challenge but it keeps telling me that I need to finish the project first. As you can see in the image that I have 100% the project and created the sql file. With the latest updates in github, I cannot push the universe.sql directly because github removed password authentication. Any help would be greatly appreciated.

1 Like

What did you do exactly on test 670?

I managed to get my self to the test folder but can’t understand what’s wrong :stuck_out_tongue:

Nvm I just deleted everything besides 690 and the other non test files and it worked as well :stuck_out_tongue:

1 Like