Running the Relational Database Curriculum in your Browser

@moT01 how do I apply the freeCodeCamp theme to my VSCode? I don’t think it’s applied.
I created a new project, and ran the code psql --username=freecodecamp --dbname=postgres but I still got the error.

Also do you know how I can install jupyter notebook?
I get this version error each time I try to install it.

I’m a little lost, are you trying to run the Relational Database courses? If so, are you running them in docker or using the browser? When you run any of those courses, the theme should be applied automatically for you. I would not recommend running the courses outside of either of those methods. If you’re trying to run them outside of those methods, they won’t work. The course adds config to your system which requires a specific system setup - which is why they need to be ran in a container.

If you just want the theme for your local copy of VS Code, you can download it from the extensions tab. Learn how here

Okay thank you, you just clarified something.
Now this is outside freecodecamp Relational Database Course.
I want to install jupyter notebook on CodeAlly VSCode, but I keep getting that error message ontop, please how can you advice I go about it?
Thank you .

It looks like you won’t be able to install that in CodeAlly at the moment. Perhaps that’s intentional. I’ll see if I can find out more.

1 Like

I believe the server was down. It started working a day later.

Hoping to get some attention on my issue stated here:

sorry for double posting about it.

I have a problem with the Bash lesson. I was going to move the header file to the website / images folder. I did this by typing mv header.png / home / codeally / project / website / images. The file has moved. You can see it in the screenshot. It is where it should be. The task is not completed, I don’t know why.

It seems like that command should have passed the tests @mettabhavana. But often, you are required to use the command in the suggestions. I would try it again with the suggested command. You should be able to use that reset button to get back to the beginning of the step if you need to. If none of that works, you can take a look at some of the troubleshooting steps at the top of this post and/or add another reply and I can try to help figure out how to get it working.

Still doesn’t work. The error that “Unable to read browser clipboard” comes up as soon as I right-click. Same thing when I use ctrl + v on the VS code/VM

Still doesn’t work. The error that “Unable to read browser clipboard” comes up as soon as I right-click. Same thing when I use ctrl + v on the VS code/VM

I’m facing this (unable to paste anything on terminal) issue also. I use chrome browser. Were you able to find a solution to the issue? Kindly reply to this if you found a solution. Thank you.

Hello Damola. I found out that if i run the lesssons through codeally (the playground tab) i was able to copy and paste on the terminal.

Having an issue on the Periodic Table Database project that may be related to the tutorials?

I’ve completed the rest of the project without issue except for the seemingly simple
" If you run ./ , it should output Please provide an element as an argument."

As you can see from my picture that is indeed the first output given when I run the code, I must be missing something simple right?

I exited from the course Learn Bash by Building a Boilerplate and when i got back it didnt pass me even if i entered write command

,i opened all the hints,changed directory but still nothing is working.Please help

If I recall @dmag171, the tests need your script to finish in order to recognize the output. Your script isn’t finishing, it’s waiting for input it looks like. Make it so it finishes running. Let us know if that works.

That user story could probably be a little more clear.

Tried letting it complete with different scenarios, running along with an argument works fine but the opening output doesn’t seem to satisfy the requirements.

I think the way the tests are currently structured, is that it’s just expecting to see the output. Not to enter anything else. Just ./element.shPlease provide an element as an argument → done.

@moT01 This was the solution, the problem is just looking for it to run with input only.

I misinterpreted what exactly it was asking for.

Hi. I’ve run into a problem with the five-programs part of this course. I’m meant to create which I have, but the CodeRoad isn’t recognizing it. I’ve made sure I’m in the right folder and the name is correct, but I’ve might have missed something? I’ve tried removing the file and re-creating it as well as change browser and tried it again, but I’m kind of stuck.

Mananged to solve it by reading moT01’s earlier post.

Here’s what I would try @equillibrium - Click the reset button - after it’s done resetting, close the terminal by typing exit into it or using the trash can icon at the top right of it - open a new terminal and do the step again.

I thought the reset button would put me back on step 1, but this worked wonderfully. I had to exit the terminal afterwords, like they wrote.

1 Like