Running the Relational Database Curriculum in your Browser

CodeAlly is unable to start the virtual server. Is there any problem with it? Tried changing browser but it still is not working.

2 Likes

try resetting the challenge,restart browser and other stuff. You can also reset the whole challenge. Click on the menu on the left of Learn Bash by Building a Boilerplate. In settings, you will have an option to reset the full challenge.
If nothing works, go to codeally dashboard which is mentioned above and delete the project and see if that works.
(I am not a mod, I am a learner like yourself. I got stuck on similar problems.)

There’s some troubleshooting steps you can try above @heil-ham. Let us know if any of them work.

It sometimes seemed to get stuck on that last step for me @tanjimanim007. A page refresh would usually allow it to finish the loading process.

Same problem. Neither restarting nor changing the browser/PC helps. It’s been like this for hours. The CodeAlly site has the same problem. But I can’t find where to go on their site.

No refreshing the page doesn’t fix this. Tried this the whole day.

It’s not working for me either seems to be a problem for everyone then.

for me CodeAlly is working but the projects aren’t. I was working on it this morning then suddenly this issue started.

I’m having troubles loading the VM’s up as well. We are looking into it - you can keep trying if you want, but there seems to be an issue right now so I don’t think it will work. Thanks for your patience.

Guys I am facing the same general issue on running the virtual server again is keeping stuck in the last loading stage and I have tried some of the troubleshooting steps you already suggested (resetting the whole course, deleting the container in CodeAlly site, etc …) but still the problem persists, someone else as any more thoughts about what to do next???

It’s been adressed already no one is able to acess it.


facing the same issue as well

There seems to be an issue with CodeAlly right now @edassgon - there might be nothing you can do to get them running at the moment, but I’m not sure. We are looking into it - I will leave a reply when we think it’s resolved. Thanks for your patience.

1 Like

Thanks for the quick reply mate, appreciate it!

Alright, I think this issue is resolved if you all want to give it another try. I was able load a container just now. If you get stuck in that spot again, a page refresh should work this time. Let us know if you are still having problems.

1 Like

I got into the container through the codeally dashboard. Through the freecodecamp link, it is still not working properly.

1 Like

I’ve arrived at the Celestial Bodies project and the course is not starting up at all. I followed the troubleshooting steps, including checking for third party cookies and possible extension interference. Everything there checks out but the course just won’t load. When it does manage to, when I try to connect to the psql server, it says that the socket can’t be found. It’s been like this for two-three days now.

Edit: I just saw the conversation surrounding this so it makes sense that it’s affected everyone. As @tanjimanim007 said, I’ve tried going thru freecodecamp and the project is still not loading.

Edit 2: Screenshot of the connection error:

Edit 3: I deleted the container and it works again.

Now it seems like the editor of the course is not showing up in my dashboard and I cannot follow the course as the challenge disappeared from my screen


@moT01 any thoughts??

CTRL + SHIFT + P and click on the CodeRoad

Hi, I’m trying to get back into my mario db session, but I am unable to get to psql in the terminal:
The prompt in the terminal is “codeally@03efae14d4df:~/project$” and typing “psql --username=freecodecamp dbname = postgres” I get: psql: error: connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: FATAL: role “codeally” does not exist
Any idea?
Thanks