Sass for loop test doesn't work. :(

Below is my code. I tried changing browser default font-size. but still not working. only text-1 is getting failed. I don’t understand what’s wrong here.

   **Your code so far**

<style type='text/scss'>
@for $j from 1 through 5 {
   .text-#{$j} { font-size: 15px * $j; }
 }
</style>

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>
   **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/92.0.4515.81 Safari/537.36

Challenge: Use @for to Create a Sass Loop

Link to the challenge:

The tests work, but there are a number of things that can interfere with freeCodeCamp’s testing.

  • The browser - What version of Chrome are you using.
  • Appearance extensions - Do any of your extensions change the appearance of websites in any way? If so, they can override CSS.
  • Privacy extensions - Are any of your extensions Adblockers, Script blockers, etc? Some of those will block the test scripts from running.
  • Browser settings - Browsers can be set to have different minimum font sizes. Some operating systems will set this value even if you don’t do it intentionally. Look at your Chrome settings to see if there are funky text settings.
  • Browser cache - Every once in a while something happens while you’re using the site (like a network connection gets interrupted at just the wrong time) and the local storage in your browser gets in a bad state. You can clear the freeCodeCamp data from your browser’s cache and try loading the page again.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.