Sass:@while error

Tell us what’s happening:

Why does it show the error that says “Your .text-1 class should have a font-size of 5px.”?
As far as I check the code in the Chrome developer tool, .text-1 is set to font-size:5px properly.
Am I missing something?


Your code so far

<style type='text/sass'>
  $x: 1;
  @while $x < 11 {
  .text-#{$x} { font-size: 5px * $x;}
  $x: $x + 1;

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>
<p class="text-6">Hello</p>
<p class="text-7">Hello</p>
<p class="text-8">Hello</p>
<p class="text-9">Hello</p>
<p class="text-10">Hello</p>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.142 Safari/537.36.

Link to the challenge:

Have you tried using Chrome or clearing your cache? It seems to be fine for me.

I’m using Chrome and the same error has occurred even after clearing the cache.
But when I used FireFox, it worked well!
I still don’t know why this happened, but anyways, thank you for your comment:)