Says I need to add my name to my account to view certification but my name is on my account

Is this what the certification should look like? Looking at google images I see others certificates look like actual certificates?

Perhaps it’s not set to “public”. This is what I see when I look at your profile:

I believe it is all public and that is weird that the points displayed is different from the ones I have displayed

I thin you might have everything set to Private. That’s the default for FCC. Try clicking on “Public” and see if it changes.

Clicking on public doesn’t change it but clicking on private does

Just checking. I have a different theme applied, so I wasn’t sure which color meant what.

Sounds like we need a GitHub Issues to report that setting your name to public isn’t having an effect. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.