Scientific Computing with Python Projects - Arithmetic Formatter

Tell us what’s happening:
When I try to run my code, I get the following messages in the console:

python venv/lib/python3.10/site-packages/setuptools/package_index.py
Traceback (most recent call last):
File “venv/lib/python3.10/site-packages/setuptools/package_index.py”, line 20, in
import setuptools
ModuleNotFoundError: No module named ‘setuptools’
exit status 1

Your code so far
Link to my code

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Scientific Computing with Python Projects - Arithmetic Formatter

Link to the challenge:

@lasjorg It appears replits are yet again having their .replit file changed even though we specify the run command in it. The reason it is happening is when the project loads from the starter link, the user see the following in the preview pane and then when the user clicks Done, the run command changes to:

run = "python venv/lib/python3.10/site-packages/setuptools/package_index.py"

and then shows the user’s error above once the Run button is clicked. I tested this myself.

@Wibble239 The way to get around the issue I mention above is to click the 3 vertical dots to the right of Files and then click on Show hidden files.

image

You will then see a .replit file under Config files. Open it and change the run command to run = "python main.py"

When you click on Run you will see an error message but it is related to your code and not a bug with repl.it

It also did it with a Node project where it wanted the run command to look like this run = "npm run start"even though you do not need to use run with that. But at least the suggested auto-correction worked (same done button was presented).

Thank you for your help with this, that solved my problem. If this happens again with the next projects I will now know how to fix this issue.

Now that I was able to run my code I could see what was wrong in my section and have now passed all of the test for this project