Scientific Computing with Python Projects - Arithmetic Formatter

The I face is the same as in this tread here the solution does not appear to be working changing the replit.nix does not help .

Your browser information:

Google Chrome -=> Version 112.0.5615.121 (Build officiel) (arm64)

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/112.0.0.0 Safari/537.36

Challenge: Scientific Computing with Python Projects - Arithmetic Formatter

Link to the challenge:

Sure I’d be happy to

Did you try just installing the missing module from the console?

# pip install pytest

Thanks for sharing the idea.

I did try to do so but unfortunately without any success.

I’m not sure installing modules / libraries functions the same way with the replit environnement as it would on my computer.

It does to a point. It always worked for me, and I’ve mentioned it to multiple people on here that says it worked for them as well, but there might be other complications like maybe version issues or something.

I just forked your replit, and guess I should have specified you need to install via the shell, not the console. I did pip install pytest from the Shell, and then your project would run past that error.

1 Like

Thanks man ,

I’ve retried this from the shell instead of the “console” and that seems indeed to have worked , the file runs now past this error :+1:

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.