Servers Cannot Be Reached

With all due respect, the website has the same problems. A blue band appears saying that servers cannot be reached to record progress

Thank you.

I have split your issue into its own thread.

Can you please provide more details so that we can help you trouble shoot your problem?

What browser are you using? Can you provide screenshots of the message? When did the problem start for you? ect

There are not, to my knowledge, any ongoing issues with the freeCodeCamp servers themselves right now. There are a number of things that can cause connection issues for individual users, users on a controlled network, a particular region, etc. It can take a while for people to trouble-shoot with you, but we’ll try our best.

As a first sanity-check, can you please open your browser tools (F12) and clear the Local Storage and Session Storage for freeCodeCamp? Depending on your browser, it will look something like this:

After that you can refresh the page and attempt logging in again.

If that doesn’t work, please report back with more information.

I am using an iPad Pro w iOS 13 so I do not have a right click Thanks

I don’t have an iPad and I don’t know off the top of my head how to clear the browser storage in a browser on an iPad, but I am confident that it can be done.

you can still delete website datas:

1 Like

I have the same problem, for about a month now, every time I tried to go on FCC to do exercises, I get a blue band at the top of he screen telling me that for whatever reason it happens to be at the time, my work cannot be saved. This is beyond frustrating. What is also frustrating is that none of FCC’s staff believes me. They just keep denying that there is a problem when it is clear there is one. I don’t get it, FCC used to be so good… what happened?

You never answered about all the debugging steps you were asked to do in your topic Servers Cannot Be Reached

that message happens if there are issues with your client, like slow connection, some data going wrong or something like that. All the steps are to solve that, if you don’t answer we imagine it went well.

But also in an other case, which is much less common but much more persistent

If you are unable to log in or keep getting “we cannot reach the server…” it may be that you have a duplicated account. To solve this issue you will need to write to
You can read more about the issue here

Please stop posting to old or unrelated topics for your issue. This topic is for help on your issue.

Thank you for understanding.

1 Like

I tried to find a relevant topic to discuss this on. Seems you all are unncessarily defensive about this, considering the tremendous inconvenience that you all are in a better position to fix than I am. Why are you all being so difficult? Don’t you think it would be better if you all just tried to fix he problem instead of denying it or being aggressive towards whoever happens to point it out. C’mon…

Only you have access to your own device so we suggest steps to take that in most cases fix the issue.
If you don’t say what’s the result, we don’t know what happened, nor we can suggest additional steps to take.

I’m trying to keep all relevant posts to helping troubleshoot your issue on a single topic so we can best help. Have you attempted the advice in


I have an iPad. I cannot do right clicking. I tried to screenshot the blue bar I got with the error message but it doesn’t seem possible to upload it. You will see from my last response to you that I did all I could, which was refresh my safari and Chrome caches but no improvement in the problem. Guess you all leave me no choice but to discuss this elsewhere to get solutions you all seem unwilling to give. Might embarrass FCC though if others learn of the problems in your website. My purpose is not to embarrass you all but to get help elsewhere that you all seem to be giving here. I was going to tell others how much I like FCC. I really cannot do that any longer unless there is some cooperation to solve this problem, Thank you.

have you tried clearing your cache as suggested in this article?

I already told you some weeks ago what the problem is and that I did what I could but it is not fixed.

“Did all I could” doesn’t tell us anything. The server is not down, so something related to your device or your internet connection is causing a problem. We want to help you figure out what it is and how to fix it, but we cannot do it without talking through the trouble-shooting with you.

So, to confirm so that we can continue in troubleshooting @Chris2020, you did in fact follow the steps in the article and successfully cleared your cache on your iPad?


I apologize. What I meant was there are limited things I can do troubleshooting wise on this iPad. I do not know any more than I am getting that light blue bar that is preventing FCC from savIng my progress in lessons. (Very frustrating especially since there is so much more cool stuff you all have and just included that I want to teach myself how to do. It is such a cool, exciting e-school). Within the past half hour I began assuming that it must be a duplicate login problem or account that you all told me about . I sent you all an email asking for help with that. In case that is the problem. Thank you for your assistance thus far. (I do mean that. I am not being sarcastic) . I look forward to your help in resolving the duplicate account problem so I can go back to using FCC to its maximum capacity. Thank you.

But did you follow the steps outlined in the linked article on how to clear your cache? If this is an issue with your specific device, then emailing for help about a suspected duplicate account will not fix the issue.

Could someone send me these steps again? This is so frustrating…