Solution Tests Failing

Tell us what’s happening:
Hi, when I put my solution into the Solution Link input box, then I press submit, I am getting the following output:

// running tests
package.json should have a valid “author” key
// tests completed
package.json should have a valid “author” key

This is unexpected because my package.json has an “author” key.

I am not sure what’s going on here, but the test is failing.

Your project link(s)

solution: https://boilerplate-npm.navyjosh.repl.co

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

	"author": "Josh",

I can’t remember for sure, but I think they want a “full” name, meaning more than one name. Unless of course, “Josh” is some famous mononym, like Cher or Sting. :wink: This is to identify you to the world, not to your friends.

I can’t remember for sure, but I have a vague memory of someone having this problem and using the full name fixed it. If not, check back.

Your code is passing for me.

BTW, please post the link to the editor in the future it makes it easier to get to the code.

https://replit.com/@navyjosh/boilerplate-npm

1 Like

I updated the name to “Foo Bar” and it’s still not working.

@lasjorg, could you post a screen shot of the test passing using my code?

It is passing for me.

I can, not sure how it helps though?


Edit: can you open the network tab in the browser and submit then tell us what you see, or post a picture of it.

1 Like

Thanks, I think my employer network policy is blocking package.json

You definitely shouldn’t be getting CORS blocked.

I also see errors in the console (12) can you look at the Console tab as well? You might be blocking something. Anyway, let us know if the problem persists on your own network.