Stuck, Code-run not working "Learn Bash scripting by..."

I have the code like the excercise asks, inside

if [[ $1 == arg1 ]]
echo true

The excercise then asks me to run it with “arg1” as the argument. I do it, it prints true but the test wont pass.

If you share a screen shot, we might be able to see if there’s something not quite right.
You can restart the step by doing these two things. If you’re confident you are doing the step right, I would try that. There’s some terminal settings that need to be applied to generate logs for the tests to use. That should reset everything and ensure they are applied.

I tried restarting Code Run and the terminal but the problem remains.

That looks correct @martin.gon22. Pretty sure the test just checks that you entered that command. Did you use the reset button you can see in your first screen shot there? I would try one more time. Hit that, and close all the terminals by typing exit into them. Open a new terminal, and run the command again.

Now I cannot get there. When I click “Start the course” and then click "Run with CodeAlly, and it starts loading, it stops and shows again the button “Run With CodeAlly” but it doesn’t do anything.
I think I’ll have to delete the workspace and start again.
Edit: Ok, i’m getting the same error even after deleting progress. I cannot open the online editor.

The issue with you being unable to run the challenge again should be gone, Martin. Thank you for reporting.

Let me know if you still have this issue.

Now I’m getting the same error in excercise 1, clicking run and saying “you should echo the correct text into the terminal”

Edit: Closed and open the terminal again and fixed it.