Stuck with greenborder challenge please help

Tell us what’s happening:

Your code so far


<link href="https://fonts.googleapis.com/css?family=Lobster" rel="stylesheet" type="text/css">
<style>
  .thick-green-border {
   border-color: #008000;
   border-width: 10px;
   border-style: solid;
 
 .red-text {
   color: red;
 }

 h2 {
   font-family: Lobster, monospace;
 }

 p {
   font-size: 16px;
   font-family: monospace;
 }

 .smaller-image {
   width: 100px;
}
 
</style>


<h2 class="red-text">CatPhotoApp</h2>
<main>
 <p class="red-text">Click here to view more <a href="#">cat photos</a>.</p>

 <a href="#"><img class="smaller-image  thick-green-border" src="https://bit.ly/fcc-relaxing-cat" alt="A cute orange cat lying on its back."></a>

 <div>
   <p>Things cats love:</p>
   <ul>
     <li>cat nip</li>
     <li>laser pointers</li>
     <li>lasagna</li>
   </ul>
   <p>Top 3 things cats hate:</p>
   <ol>
     <li>flea treatment</li>
     <li>thunder</li>
     <li>other cats</li>
   </ol>
 </div>

 <form action="/submit-cat-photo">
   <label><input type="radio" name="indoor-outdoor" checked> Indoor</label>
   <label><input type="radio" name="indoor-outdoor"> Outdoor</label><br>
   <label><input type="checkbox" name="personality" checked> Loving</label>
   <label><input type="checkbox" name="personality"> Lazy</label>
   <label><input type="checkbox" name="personality"> Energetic</label><br>
   <input type="text" placeholder="cat photo URL" required>
   <button type="submit">Submit</button>
 </form>
</main>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36.

Challenge: Add Borders Around Your Elements

Link to the challenge:

I ran the tests on your code and it worked just fine. I’d recommend ensuring your browser is set to 100% zoom, no extensions access FreeCodeCamp.com, and switch to another browser if that fails.

Your code works fine for me. Maybe try to use a different browser

thanks i appreciate the help, spent hours trying to figure this out on my own…

thanks, it finally worked after couple hours, not sure what made the difference

You are quite welcome!

In the future, you are able to edit your post - I recommend refraining from making multiple posts in the forums for the same issue. :slightly_smiling_face:

sorry, this is why i didn’t want to post on here, because i didn’t know how and knew i’d make some mistake posting

No worries! We are all here to learn! If you click the “profile” link in the top right, then click the little envelope icon, you should see a message from discobot. That message will take you through a tutorial of the basic features of our forum.

You are missing the closing graph bracket for the .thick-green-border selector (I’ve added a comment above where it is missing)
You probably added it at some point without noticing

1 Like