Sudoku Solver: All test passing except for the last two

Hi there, I have been working on the Sudoku Solver project for the last couple of days. All tests are passing except for the last two. I can’t figure out why the last two tests aren’t passing; all of my unit tests and functional tests are passing when I run them in Furthermore, whenever I submit my project link, inside of it prints out in the console “undefined” twice. Any help is appreciated. Thanks in advance!

Project link:


Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.141 Safari/537.36.

Challenge: Sudoku Solver

Link to the challenge:

I have figured out the error; the reason why the unit tests and the functional tests weren’t passing is because two of my units tests and one of my functional tests had no assertions.

1 Like

hello @egorushakov13 , can you give my code a look,
My unit tests don’t work.
here is my :

Hi, a are you sure it’s because assertions? I have them in my code, but still tests fails on fcc site.

Hi, have you solved your problem? I’ve problem with tests too.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.