Survey Form- Can't see my <p> entry

I have passed all the user stories but my layout needs work. My radio buttons and text areas are jammed together and I can’t find the <p> entry for one of my questions.

I think my mistake is somewhere in line 38 but nothing I’ve tried has worked

The link is here:

image

You have an error on line 29.

1 Like

I removed it and it didn’t change anything, any advice?

You still have syntax errors. Also please include the test script in the Codepen.


I would suggest switching the Syntax Highlighting on Codepen. It will help catch syntax errors.

Go to your Codepen profile settings. Under “Editor Preferences” switch the Syntax Highlighting to Oceanic Dark and save the setting. Go back to the pen and make sure your new setting is working, the code highlighting will be using different colors. If there are issues you should see code marked in red. That is the new Syntax Highlighting showing you where the problems are.

Press the down arrow to the right of the code boxes and select the “Analyze” option. You can also use a validator tool.

2 Likes

That syntax hillighting was helpful I didn’t know about that feature. I now have no outstaning errors. But it hasn’t helped. Is the test script the tests that you run on the page? They are all fine, but I just want to tidy it up and recover my <p>

You still have errors though.

  1. You didn’t close the select element.

  2. The input element is an empty element, it does not take any content so it doesn’t have a closing end tag.


I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).