Technical Documentation Page - Build a Technical Documentation Page

Tell us what’s happening:
Describe your issue in detail here.
I’m having difficulty scaling this, i’ve linked the css to the html using but it’s still the same error i’m seeing. Anyone please help.

  **Your code so far**
/* file: index.html */

<head>    
<link rel="stylesheet" href="styles.css">
</head>
<main id="main-doc">technical documentation
<section class="main-section" id="analysis_on"><header>analysis on</header><nav id="navbar"><header>live</header><a class="nav-link" href="#analysis_on">analysis on</a></nav><code></code><li><p></p><p></p></li></section>
<section class="main-section" id="man_op"><header>man op</header><nav id="navbar"><a class="nav-link" href="#man_op">man op</a></nav><code></code><li><p></p><p></p></li></section>
<section class="main-section" id="java_script"><header>java script</header><nav id="navbar"><a class="nav-link" href="#java_script">java script</a></nav><code></code><li><p></p><p></p></li></section>
<section class="main-section" id="party_life"><header>party life</header><nav id="navbar"><a class="nav-link" href="#party_life">party life</a></nav><code></code><li><p></p><p></p></li></section>
<section class="main-section" id="too_thou"><header>too thou</header><nav id="navbar"><a class="nav-link" href="#too_thou">too thou</a></nav><code><li><p></p><p></p></li></code></section>
</main>
/* file: styles.css */

  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/103.0.0.0 Safari/537.36

Challenge: Technical Documentation Page - Build a Technical Documentation Page

Link to the challenge:

Yes, you did link the stylesheet to the HTML, but I don’t see any CSS in the styles.css editor. Did you add CSS in there? Specifically, did you a media query in there? You’ll need to do that to pass the last test.

Also, even though you are passing all the other tests you are actually not doing the navbar menu correctly. You should only have one nav element on the page, it should have an id of “navbar” and it should contain all of the links to the sections. Technically, ids should be unique, which means only one element on the page can have an id of navbar.

Worked like magic, thank you very much!