Technical Documentation Page - Build a Technical Documentation Page

Tell us what’s happening:

on the 8 step of the build a technical document i replaced the space by a underscores (_) for all my id that match the text of my first child main sections but it still does not let the code pass

Your code so far

<!-- file: index.html -->
<!DOCTYPE html>
<html lang="en">
  <head>
    <meta charset="UTF-8">
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
   <title>Basketball: Rules and Basic Gameplay</title>
    <link rel="stylesheet" href="./styles.css">
  </head>
  <body>
    <main id="main-doc">
      <h1>Basketball: Rules and Basic Gameplay</h1>
      <section class="main-section" id="introduction">
        <header>
          <h2>Introduction </h2>
        </header>
      </section>
      <section class="main-section" id="equipement">
        <header>
          <h2>Equipment </h2>
        </header>
      </section>
      <section class="main-section" id="game_setup">
       <header>
        <h2>Game Setup</h2>
       </header>
      </section>
      <section class="main-section" id="basic_gameplay">
       <header>
        <h2>Basic Gameplay</h2>
       </header>
      </section>
      <section class="main-section" id="conclusion">
       <header>
        <h2>Conclusion </h2>
       </header>
      </section>
    </main>
  </body>
/* file: styles.css */

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/123.0.0.0 Safari/537.36

Challenge Information:

Technical Documentation Page - Build a Technical Documentation Page

Check your html closing tag. I didn’t seen it in your html file.

Also check your all id wordinghave it’s first letter lowercase.

Basketball: Rules and Basic Gameplay

Basketball: Rules and Basic Gameplay

Introduction

Equipment

Game Setup

Basic Gameplay

Conclusion

i just check everything but it still not working

Post your code with three ``` back ticks in a separate line, before and after your code block.

here the id and content of the h2 do not match. make sure they all match

Thank you my bad i didn’t check properly

1 Like