Technical Documentation Page - Build a Technical Documentation Page

Tell us what’s happening:

I am having issue with this and the one below?

Each .main-section should have an id that matches the text of its first child, having any spaces in the child’s text replaced with underscores (_) for the id’s.

Each .nav-link should have an href attribute that links to its corresponding .main-section (e.g. If you click on a .nav-link element that contains the text “Hello world”, the page navigates to a section element with that id).

Your code so far

<!-- file: index.html -->

  <link rel="stylesheet" href="styles.css" /> 
  <nav id="navbar">
    <header>Acer Knowledge Base</header>
<ul>
  <li>
    <a class="nav-link" href="#Repair_Process">Repair Process</a>
  </li>
  <li>
    <a class="nav-link" href="#Troubleshooting_Steps">Troubleshooting Steps</a>
  </li>
  <li>
    <a class="nav-link" href="#Warranty_Registration">Warranty Registration</a>
  </li>
  <li>
    <a class="nav-link" href="#Promo_Inquiry">Promo Inquiry
    </a>
  </li>
  <li>
    <a class="nav-link" href="#Repair_Turn_around_Time">Repair Turn around Time</a>
  </li>
</ul>
</nav>
<main id="main-doc">   
<section class="main-section" id="Repair_Process">
    <header>Repair Process</header>
    <p></p><p></p>
    <code></code>
    <li></li>
</section>
<section class="main-section" id="Troubleshooting_Steps">
    <header>Troubleshooting Steps</header>
    <p></p><p></p>
    <code></code>
    <li></li>
</section>
<section class="main-section" id="Warranty_Registration">
    <header>Warranty Registration</header>
    <p></p><p></p>
    <code></code>
    <li></li>
</section>
<section class="main-section" id="Promo_ Inquiry">
    <header>Promo Inquiry</header>
    <p></p><p></p>
    <code></code>
    <li></li>
</section>
<section class="main-section" id="Repair_Turn_around_Time">
    <header>Repair Turn around Time</header>
    <p></p><p></p>
    <code></code>
    <li></li>
</section>
</main>
/* file: styles.css */
@media screen and (max-width:750px){
  width:50%
}

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/124.0.0.0 Safari/537.36 Edg/124.0.0.0

Challenge Information:

Technical Documentation Page - Build a Technical Documentation Page

Hi @llenrad

You have white space in the id attribute value.

Happy coding

1 Like