Test failing after right steps

I have added all the steps as instructed in the help section still getting the failure.
Server is running fine.

solution: https://boilerplate-mongomongoose.amankumar51.repl.co

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:86.0) Gecko/20100101 Firefox/86.0.

Challenge: Create a Model

Link to the challenge:

This isn’t going to work, the function will never run:
(why should it run, there’s no request coming in that waits for a response)

app.use(function(req,res,next){
  try{
     const person=mongoose.model("Person",personSchema);
  } catch(err){
     console.log(err);
  }
next();
});

Next issue is that the tests look for a model named Person (uppercase), yours is lowercase.

After removing the app.use still it is not working.

try {
  const Person = mongoose.model("Person", personSchema);
} catch (err) {
  console.log(err);
}

still not working

I’ve edited your post for readability. When you enter a code block into a forum post, please precede it with a separate line of three backticks and follow it with a separate line of three backticks to make it easier to read.

You can also use the “preformatted text” tool in the editor (</>) to add backticks around text.

See this post to find the backtick on your keyboard.
Note: Backticks (`) are not single quotes (’).

What’s your current code? You haven’t updated the repl.

Do you get any errors?

Have you removed this from the top of your file?
let Person;

Solved.Thnks jsdisco.