Test keeps failing onthe topic "nest an anchor tag within a paragraph" for html and html 5

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**

<h2>CatPhotoApp</h2>
<main>

<a href="https://www.freecatphotoapp.com" target="_blank">cat photos</a>

<img src="https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg" alt="A cute orange cat lying on its back.">
<p>View more <a href="https://www.freecatphotoapp.com". cat photos</a></p>

<p>Kitty ipsum dolor sit amet, shed everywhere shed everywhere stretching attack your ankles chase the red dot, hairball run catnip eat the grass sniff.</p>
<p>Purr jump eat the grass rip the couch scratched sunbathe, shed everywhere rip the couch sleep in the sink fluffy fur catnip scratched.</p>
</main>
  **Your browser information:**

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.61 Safari/537.36

Challenge: Nest an Anchor Element within a Paragraph

Link to the challenge:

Hey, @scoder321 . Notice anything suspicious right after the ending " of the address?

Also, are you going to use the same address in two different areas? I believe the “cat photos” anchor tag ( “a” ) on the top could be gone.

1 Like

Also, the instructions say, “Do not create a new anchor tag.”

1 Like

sorry, i am very new to this. do you mind editing it and sending it to me. thanks

I actually can’t, since you are the one who has to do the challenge and run the test. Still, let me try to assist a bit:

< a href=“https://www.freecatphotoapp.com” target="_blank">cat photos

This entire line above could be gone as you are adding it below.

< p>View more < a href=“https://www.freecatphotoapp.com”. cat photos< /a>< /p>

Here, the “.” after the address should be gone.
Test it again and see what happens.

thank you so much this really helps

i am still not sure why i am having one more problem. it says that my a element should be rested within the p element and thati should only have one a element?

Can you share the code you currently have?

1 Like

i did its right at the top of the screen

You need to get rid of what you added. You were supposed to use the existing <a> at the top and add your <p> around that.

1 Like

thank you so much for all the help

You’re welcome. Did it pass?

no and im not sure why. i asked for help and got the exact answer and typed it in but i just wont pass.

Make sure it looks like this:

1 Like

it looks exactly like that

thank you so so much i have figured out my mistake. you really really helped.

1 Like

Excellent. I’m happy to hear it. :slight_smile:

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.