Test Not Passing in NPM challenge

Tell us what’s happening:

So I edited the code by visiting the repl link provided by FCC and did exactly as said in the challenge. I then copied and pasted the link in the box of the challenge and submitted. It showed the tests as failed. I tried again and again and it shows failed. Sometimes it showed test timed out as well. I don’t know what’s going on. I even tried removing all other key-value pairs inside the JSON file and add the author key only, and it didn’t work.

Your code so far

This is the link I submitted:


Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0.

Challenge: How to Use package.json, the Core of Any Node.js Project or npm Package

Link to the challenge:

I’m afraid you are submitting the wrong url.

You should use the one of the running application, not the repl environment.

For reference:

1 Like

Here I have answered a person struggling with the same problem

1 Like

Thank you for your help @Marmiz & @Freak_A_tick. I ran the repl by hitting the run button and the console automatically ran npm start. But the command threw an error:

I can’t see any browser window at the top right. I think it’s due to this error. Any idea how to fix? Seems like Express module is missing. Should I run npm install?

Thanks for the help. I sorted it out by running npm install and then the Run button.

EDIT: You need to open the link in a new tab and then copy the URL. Then only it passes.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.