Test Runner Failed - Learn Bash Scripting by Building Five Programs

Run this next

mv .mocharc.json.save.1 .mocharc.json

Then retry the step.

It worked for now!

Okay check the mocharc file again. It should say 941 instead of 940 now?

No, It doesn’t, and it felt weird because the challenge was to type ‘help let’ on the terminal, and by doing only that the challenge completes itself usually, but on this time I needed to click on the “run” button.

Did you press continue after you ran the test?

Yes like always, I finished another one.

Run more .mocharc.json on challenge prob number 942:

Run more .mocharc.json on challenge prob number 943:

It seems to not be updating, I wonder if that is going to affect my freecodecamp website’s progress

Yeah, not sure.

Try to do another soft reset. Maybe that will fix something.

Same result

It seems a little bit bugged because apparently the challenges are updating but the files not. Not sure tho

Also, maybe the challenge completion would be stuck on 66%?

I wonder if I change the mocharc with nano everytime it would work normally xd

I am going to sleep for now and I’ll continue exploring more tomorrow

I don’t think this is a good solution. Every soft reset my files don’t update, only the challenge ones.

Also now I can’t find the .machorc.json.save.1, and all the other saves has the same code. I tried changin machorc with nano again but it doesn’t save.

The challenge progress count normally, I advanced to the 67%, but any soft reset will undo my changes to the file. Also it is not very productive for the learning aspect being worried about all of this instead of just concentrating on learning.

Maybe at this point it is just better to restart the course, and hope this bug doesn’t happen again.

yes you can certainly delete the container and start again.
This is just one option I was exploring in order to avoid that.

It feels like I could still finish the course, but I worry if the freecodecamp site will count it as completed

I don’t want to tell you what to do. I don’t have enough information to help you fix the issue (I’m basing everything on the other thread with the developer of the course). He may be able to help you further at some point (its the weekend so you may have to wait a few days for his attention).
It is entirely possible he may advise you to delete the container anyway.
With respect to fcc counting it, again I don’t know how they do the checking for this but in the end, this is not a certificate project so the only thing you get when you finish it is a check-mark that only you can see.
So it is up to you. Let me know if you want me to try to get the developer’s attention on your behalf on Monday or if you will go ahead and delete and start again.

I think I’m going to continue normally and if anything else happen I’ll reset the course. I think the checkmark on the site is nice to see your progress along the weeks, but if this isn’t very impactful then I don’t think chatting with a dev will be necessary. But I think it is a good idea to communicate that this problem exist to try fixing it and avoid that more ppl have this issue.

Thanks for looking into this @SilencePlease & @hbar1st - this is certainly a problem we need to try and fix, and this will help. I only glanced over everything here, I will try to take a closer look when I get a chance.

To clarify one thing a little - the progress within a course is different than the progress on the freeCodeCamp site. While you are in the course, CodeRoad keeps track of what step you are on. It’s only after you finish the last step that your progress gets saved to your freeCodeCamp account. So if you make it to, and pass, that last step in any way, it should save to your fCC account. More info and image here. After you pass the last step, you get the “Tutorial Complete” popup in that image, and then when you click “continue”, it sends a request to freeCodeCamp basically saying “I finished this course” - and then you get the checkmark on your account.

1 Like

i have same problem , Test Runner Failed please help

I had the same issue and it was because permission was denied for countdown.sh . So I did chmod +x countdown.sh and the test passed automatically

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.