Test suite forked pen technical help

Tell us what’s happening:
When I click on the run test, the button is neither showing red or green color, then, how do I know my progress? Thanks

Your code so far

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36.

Challenge: Build a Random Quote Machine

Link to the challenge:

If you click on the red/green/yellow Tests X/12 button it will show the test progress. If you are not seeing red or green, I’d guess that you are having a JSON error and timing out? Can you post a link to your codepen so we can test ourselves?

have you selected the project from the drop down menu? (just asking - sometimes it is the sillies things that give issues)

1 Like

Yes,I did…:-):grin:

Above is my forked pen’s link…Is the issue due to my renaming the pen? I added the name of the project in the title of the forked pen, hope, it is allowed?When I click on the different buttons, there is no response at all. Looks like a bug though. I have not yet finished doing the test, was just trying few of the tasks given in the project and I thought why not see the result of my test for the ones that I have already tried out and then I see that the result buttons dont respond to click. :slight_smile:

Hi @meeramenon07,
I forked your code but failed to detect where the problem could be. But when i forked This example app provided in the exercise, deleted all the code and pasted your code in its place, it worked just fine. Just do the same. There could be a bug somewhere like you mentioned.

1 Like

Ok, Thanks, will try like that then. Cheers.

I tried doing just that even now, it is the same bug…gives me message talking about referral header

Hi @meeramenon07, here’s what I did.

  • codepen only expects the code you’d put within the <body> </body> tags in HTML. (No need to include the body tags). And the script tag should be right before the closing body tag. So I did two things;
    • first moved the script so it was before the closing body tag and ran the tests
    • next deleted the <html> </html> and <body> </body> tags and ran the tests

Each time the tests run but gives a Bad Path /boomboom/v2/index.html error so results aren’t being seen. You can put that in Google and read some of the Stack Overflow responses from others that were seeing this to see if the cause is the same as yours.

Ok, thanks, will try that out too. cheers