Testing Bug in Browsers

Hi, I was doing a coding lesson in the HTML CSS Responsive Web Design Certification with Microsoft Edge Browser (Windows 11). I was working on the HTML Registration Form step 17, and I kept getting the error requesting I add a space after the colon. I spent a very long hour trying to figure out what the issue was. I googled for an answer, and I decided to test the code on a different browser.

When I ran my code on the latest version of Firefox, there was no issue. The feedback showed I completed the lesson successfully. I tried the same test on Chrome, and Chrome showed the same error from Edge saying I needed to include a space after the colon(which I already did).

Can anyone tell me what is going on?

Can you show us your HTML that isn’t passing using EdgeChrome?

To display your code in here you need to wrap it in triple back ticks. On a line by itself type three back ticks. Then on the first line below the three back ticks paste in your code. Then below your code on a new line type three more back ticks. The back tick on my keyboard is in the upper left just above the Tab key and below the Esc key. You may also be able to use Ctrl+e to automatically give you the triple back ticks while you are typing in the this editor and the cursor is on a line by itself. Alternatively, with the cursor on a line by itself, you can use the </> button above the editor to add the triple back ticks.

2 Likes

Here is part of the code on step 17. It was deemed wrong in the edge browser. I copy and pasted the same code in Firefox, and it was running correctly.

 <fieldset>
        <label>Enter Your First Name: <input></label>
        <label>Enter Your Last Name: <input></label>
        <label>Enter Your Email: <input></label>
        <label>Create a New Password: <input></label>
</fieldset>

Hmm, I just copy/pasted this HTML into step 17 using Edge (on both Windows 11 and Linux) and it passed on the first try in both browsers. What version of these browsers are you using? What OS?

I’m using Windows 11 Microsoft Edge Version 115.0.1901.188 (Official build) (64-bit)

Firefox is up-to-date. Version 115.

Yep, that’s the same version of Edge I’m using and your HTML is passing fine for me.

I don’t know, but I’m tempted to say it is something on your end. Perhaps somebody else will chime in with some ideas.

Has there been any update on this issue so far?

I agree, it sounds like a problem with your local browser.

What should I do? Clear my cache and cookies?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.