Testing is not working

Hei all,

reaching out because the test suit is not working anymore on my system.
It is telling me:

The Page at moz-nullprincipall: says:
Test suites depend on access to localStorage. Please enable third-party cookies in the browser. See documentation for your browser for instructions on how to enable third-party cookies. Thanks and Happy Coding!

Regardless that third-party cookies are enabled (checked it a few times :face_with_raised_eyebrow:). That is happening with Firefox. It is working Chrome though.

Did somebody run into the same problem?


EDIT: I wasn’t specific enough. I am referring to the test-suit for testing the project. Which is included with https://cdn.freecodecamp.org/testable-projects-fcc/v1/bundle.js to our projects.

I do have the same problem in Firefox and Chrome.

@codely @Akloib. Which tests are you referring to?

The Test suite, we use to test our project to make sure we gain full mark.

Give a message like

1 Like

Yes exactly, thx @codely.

I have already seen this reported and discussed but I don’t know where
It’s an issue with Firefox only it seems, maybe a recent update

It is also in Chrome

in chrome as long as you activate the local storage has not given issues yet

then should i use chrome?

have you tried with chrome? does it work there?

what happens if you enable third party cookies?

Now it work.

How to enable it now firefox?

I don’t have Firefox
though in Firefox it seems to persist even when enabling it

I have tried everything I can think of to enable it in Firefox, but it has not worked.

For now, I suggest campers use a browser with the latest Chromium Engine.

1 Like

I have already contacted Codepen about this issue. For now, there isn’t really anything we can do about it on our end.

Here is a thread with more info.


I am giving a proof that the problem is with CodePen.

This shot you see the text is working.

that is not in codepen, the issue is with codepen

That’s what I said


Encountered a same problem today. No testing on CodePen.io working in Chrome or FF. Changing browser settings doesn’t help.