That Darn CAT (is hiding!)

Tell us what’s happening:
Describe your issue in detail here.
No image displays. I´ve been over and over the code and for the life of me I don´t see what´s wrong.
My test results:
// running tests Your image should have a src
attribute that points to the kitten image. Your image element’s
alt attribute should not be empty. // tests completed

As can be seen I have the src attribute and itś alt.

  **Your code so far**

<h2>CatPhotoApp</h2>
<main>
<img src=¨https://cdn.freecodecamp.org/curriculum/cat-photo-app/relaxing-cat.jpg¨ alt=¨A cat relaxing¨>
<p>Kitty ipsum dolor sit amet, shed everywhere shed everywhere stretching attack your ankles chase the red dot, hairball run catnip eat the grass sniff.</p>
<p>Purr jump eat the grass rip the couch scratched sunbathe, shed everywhere rip the couch sleep in the sink fluffy fur catnip scratched.</p>
</main>
  **Your browser information:**

User Agent is: Mozilla/5.0 (X11; Linux x86_64; rv:98.0) Gecko/20100101 Firefox/98.0

Challenge: Add Images to Your Website

Link to the challenge:

I think there might be something wrong with your double quotes. Once I replace them with ascii double quotes then your challenge passes. How are you putting your code into the challenge?

This has happened before with apple phones, and a different type of quote mark.

PERHAPS THERE IS A SIMILAR SOLUTION TO THIS AVAILABLE.

As said you should use normal double "" or single '' quotes.

According to charCodeAt you are using a diaeresis which definitely isn’t what you want (a diaeresis is the two dots above the i in naïve).

1 Like

Thank you. I had to do some work to figure out why my keyboard was outputting diaeresis instead of quotation marks. Turns out I have to hit spacebar after entering quotation marks. A Linux querk maybe? I duno, I’m new to Linux but I’ve already fallen in love with it. Windows is such garbage lol. Thanks for the assist. I was going nuts with this!

I’ve been using Linux since '94 and I have never run into this. I’m also typing this using FF 98 and “double quotes” are working just fine (as you can see). I am curious as to why you are having this problem. Can you give more details? What distro are you using? Does this happen in other browsers or text editors?

1 Like

What country/language/keyboard setting did you set the OS up to use? Is the keyboard a standard US keyboard layout?

Interesting.

ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤㅤㅤㅤ ㅤㅤ ㅤㅤㅤㅤㅤ ㅤ ㅤㅤㅤㅤ ㅤㅤㅤㅤ ㅤㅤㅤ ㅤㅤㅤㅤㅤ