The site doesn't seem to be remembering what I finished lately

The site doesn't seem to be remembering what I finished lately
0

#1

Hello FCC,

I really like FCC but the past couple days I’m noticing an issue and perhaps someone had a similar problem and can help.

I’m into the Javascript section of the lessons and the past couple days the lessons I’ve done and finished/passed don’t seem to be showing up in my map. My Number next to my pic in the upper right hand corner is staying the same,…and I did all these lessons the other night:

Compound Assignment With Augmented Addition Aug 16, 2016 Aug 17, 2016 View solution
Compound Assignment With Augmented Subtraction Aug 17, 2016 Aug 20, 2016 View solution
Compound Assignment With Augmented Multiplication Aug 17, 2016 Aug 20, 2016 View solution
Compound Assignment With Augmented Division Aug 17, 2016 Aug 20, 2016 View solution
Convert Celsius to Fahrenheit Aug 17, 2016 Aug 20, 2016 View solution
Declare String Variables Aug 17, 2016 Aug 20, 2016 View solution
Escaping Literal Quotes in Strings Aug 17, 2016 View solution
Quoting Strings with Single Quotes

the problem is I’ve done more lessons since then. The 17th was Wednesday and that was not the last time I was on FCC.

So twice now when I’ve logged back in,…it drops me back to the Compound Assignment section and I have to do it over.

I’ve done the Convert Farhenheit to Celsius twice now as well,…just now did it again for a second time when I first did it the other night. Right this second I’m on Escaping Literal Quotes in Strings,…again.

To my recollection I should be on: Concatenating Strings with Plus Operator, but that’s locked to me now. As is the lesson before it.

I’ve looked around and googled and tried to see if anyone else has this problem but with no luck.

I’m almost nervous to leave the site or close my laptop down because I don’t want to have to do the Compound Assignment or Celsius lessons for a third or fourth time.

I’ve never had this problem before. FCC has always worked flawlessly for me. I haven’t changed computers (though I do bounce between 2 laptops I don’t think that would matter since my account is the same account.)

So…help? Anyone else have this problem?

I’m very, very serious about finishing this course. I know it will take a long time and be a lot of work. However I don’t want to get stuck doing the same lessons over and over and not advancing through The Map.

But I can’t figure out why it’s doing this.


#2

another odd thing…

I clicked the FCC logo on the upper left side and it took me right to Concatenating Strings,…the exact lesson I thought I should be on,…however when I look at the map you see that Escape Sequences In Strings is blank,…not completed,…even though I did complete it. If you look at the tabs you’ll see I’m on the lesson I thought I was on,…but the map doesn’t reflect that. According to the Map I shouldn’t be there. That lesson is One Lesson past where it’s saying I am. That’s a conflict of some type. Escape Sequence in Strings I’ve already done before the other night,…but the map is not reflecting that. The only reason the first four showing on the map, (convert, declare, escaping, quoting) are grayed out right now is because I just did them again in the past hour. But they should’ve been greyed out already from when I did them the other night.

I don’t know there’s something strange going on.

Perhaps the 145 number isn’t changing because I am and should be on Concatenating Strings and when I complete that the number will increase? It’s hard to know since the Map isn’t numbered.

It seems I was dumped quite a few lessons behind where I actually was and had to do them again. That’s very odd to me because like I said before, FCC has worked flawlessly for me up to this point.

…I just don’t want to lose my work and I sure don’t want to have to keep doing the same lessons over.

Edit: 5:53EST I pushed past the lessons I’d already done and The Number next to my pic started going up again. So that’s good.


#3

If you’re repeatedly having problems with it erasing your progress, I would suggest submitting an issue on the repository.

Should get more visibility there, or someone can tell you if there’s a fix.


#4

Maybe I figured out what happened.

I think the other night after I’d done a bunch of lessons I wanted to go back and do them again to cement the ideas, so I went back a few and clicked ‘Reset’ to reset the code. But I think it reset all the lessons I’d just done and not just the code for that one particular lesson.

Maybe that’s why it locked me out of completed lessons and I had to do it again.

That would make some sense.

But if I clicked the FCC icon in the upper left corner it would jump me back to the right spot,…however the previous lessons still showed as incomplete.

…not sure if that’s a bug or just a weird quirk.

Anyway I’m past that point now and things seem to be registering.

I just logged into FCC with my second laptop and it’s showing me being where I’m supposed to be.

So I guess the lesson learned is: Do Not hit the Reset Button.


#5

I think for a challenge to register as completed, you need to click the “Submit and go to the next challenge” button in the modal that pops up.


#6

I’ve been caught out by that before :slight_smile:

In my rush to move on, sometimes I hastily click outside of the modal (which closes it) without actually submitting.