Trouble with links on my website

I made a website here: http://www.thestoicdirectory.com

It’s pretty basic, made up of links. The problem, however, is that when the links are clicked, the address doesn’t change to the website it’s linking to, but keeps my domain in place.

For example, when the first link is clicked, it should bring you to the internet encyclopedia of philosophy(http://www.iep.utm.edu/), which it does, but doesn’t display that; it keeps my domain name.

Also, when the catagory of “books” gets a link clicked, it doesn’t even bring you to Amazon, it just make the page go blank.

I’ve had trouble with this on my personal portfolio as well, I had to write some javascript that opens the intended page.

Does anyone have any idea what is causing this? On my local machine, everything works fine. It only happens when I publish the site.

EDIT: could it be that I’m using hosting from AWS, but got my domain from godaddy, and within godaddy, I’m masking the AWS address? When you “view page source”, you don’t get the actual source, but something from godaddy with a link to the actual source.

Because you’re using frames…

The links are updated in the 2nd window frame, and the original url (top-level) on the browser is not updated.

<frameset rows="100%,*" border="0">
  <frame src="http://s3.us-east-2.amazonaws.com/thestoicdirectory.com/index.html" frameborder="0" />
  <frame frameborder="0" noresize />
</frameset>

Yes, I think it’s because I’m using two different services. I purchased the domain from godaddy, and hosting from Amazon. I think there’s a way I can transfer that domain name over to AWS, but I’m unsure.

I will look around on the site, hopefully all goes well :o
haha, thank you @owel

Wait, so, do you think this is the problem? I’m completely new to this area( i.e. publishing, domain names, hosting.)

It’s got nothing to do with using 2 different services. This is a side effect of using frames. The url of the browser will only show the original url of your site.

If you access this url,

http://s3.us-east-2.amazonaws.com/thestoicdirectory.com/index.html

then you won’t be loading the frames.

Did you create that frame?

No, I didn’t create the frames.

On godaddy.com, I “masked” this link:
http://s3.us-east-2.amazonaws.com/thestoicdirectory.com/index.html

with the domain name I purchased. Godaddy created the frames. So, that not only blocked and replaced my own meta description(I wrote a new one from godaddy), but layered my actual source code, I guess.

I figured out though that on AWS, I can transfer the domain over to their service(for the low price of $12.00) *~`

Yup, looks like GoDaddy fakers tried to pull a fast one on you.

[quote]I figured out though that on AWS, I can transfer the domain over to their service(for the low price of $12.00)
[/quote]

No, that $12 a year is you transferring your domain registration to Amazon. If your registration is still good at GD, you don’t have to do that. You can transfer it to AWS when it’s time to renew at GD, if you wish.

I see, you’re using S3. You can pair your S3 bucket with a domain name. Use the AWS Route 53 service. Then you create a ZONE at Amazon Route 53. It’s not expensive. $0.50 per domain name you want to make active on Amazon + $0.40 cents per million queries. — so yeah, $0.51 total.

Then Amazon will give you (4) Name Servers (NS) associated with your S3 bucket, linked to your S3 location.

Now, go to your GoDaddy control panel and enter those same (4) Name Servers as custom DNS.

You need to follow Amazon’s instructions on your S3 account. Basically, you’ll create an S3 bucket whose name is “yourdomain.com” , and a second bucket with the name “www.yourdomain.com” which is just rerouted to your original “yourdomain.com” bucket. They have details on Amazon AWS on how to do this.

PS: Above Name Servers settings are specific to my account and domain name. Yours will be probably slightly different. Check your AWS control panel on what you need to use.

Thanks for replying with your expertise! I appreaciate it soo much!!

Ok, I did that. It still has frames on the site, I cannot get rid of them. In GoDaddy, am I suposed to be “forwarding” the Amazon link that I get from the bucket, to the domain name?

I indeed created the buckets and everything. I just added those custom Nameservers, too. But there’s still a frame covering my site.

Then your site is still being served from Godaddy, and not Amazon S3.

^^^ Either that…

or you have a cache DNS entry on your computer, which still points http://www.thestoicdirectory.com12 to GoDaddy’s servers. In which case, you need to clear your DNS cache.

In OSX, I have to do this. If you’re using Windows, google what specific command you need to type.

sudo dscacheutil -flushcache;sudo killall -HUP mDNSResponder

I’m running Ubuntu 16.04. I’ll check it out.

Thanks again, @owel.