Tutorial Videos on FCC dont load

Hi everyone!

I can´t seem to see the videos of the tutorials. I suppose the problem is on my side for some reason, yet google and switching to other browsers didn´t help so I need to bother you guys…

The loading doesn´t get past this step:

Please tell me what the problem is and how I can fix this if you can, I would love to know the explanation!

Thanks in advance and stay safe :slight_smile:

Welcome, karel.

This does seem to happen to a few campers. Let us try to get to the bottom of it:

  1. Do you have any browser extensions installed with access to freecodecamp.org?
  2. Do you use a VPN?
  3. Does your network go through any specific proxy? (Company network or otherwise)
  4. Are you able to view the video on YouTube? Here is the link: https://youtu.be/H6qtjRTfSog

Ok, so now - for some reason - it works, although it only redirects me to youtube to watch it there and wont start on the site.

Regarding your questions:
1.) I tried Edge, Internet explorer (which I both never use - so no extensions) and disabling all 4 extensions in Firefox (Privacy Badger, HTTPS Everywhere, Adblocker Plus and Mendeley) but that didn´t work.
2.) No (not yet)
3.) No
4.) Yes

Could it have something to do with Jupiter Lab though? I was running that via localhost…

I doubt this is the issue, but just for just: which OS are you using?

Not likely. This would be an odd security issue.

@raisedadead This issue has come up three times. Is there any way it could be our side?
If I'm logged, videos won´t load

Hey, thanks for the input so far! :slight_smile:

I am not quite sure, what exactly could be the information that will help you, so here are a few stats:
Windows Version: 10.0.19041 Build 19041
Firefox Version: 81.0 (64-Bit)

Hope that helps! If there are any more stats you need to assess the situation, I will gladly provide them.

Cheers!

Update: with the aforementioned stats, everything now works - but I would nevertheless want to understand what the problem was so that I can solve it on my own the next time something similar occurs, instead of taking up peoples ressources to help me solve it - so if possible, please share the “solution” with me

Hi @karel.h

Thanks for reaching out and reporting this to us. I am unable to reproduce this myself.

Will you be OK to take a few screenshots of the network tab on your developer tools (for whichever browser that you use) next time you see this?

By the looks of it perhaps something is blocking the embed from loading.

We would need more insight of the cause.

For anyone looking to fix I have created:

I was having this issue on firefox - videos wouldn’t load so I always switched to chrome if I had to see them. I disabled all my firefox security settings, reloaded the page and it works. I re-enabled all the same settings - and it still works - and when I go to any video now, it works.

Tried a few things to get them to break again, couldn’t do it.

1 Like

Going to mark this as resolved with the workaround from @moT01 for now. Please let us know if this still is the case by reporting on the GitHub issue tracker.