Use @for to Create a Sass Loop another one

Use @for to Create a Sass Loop another one
0

#1

Tell us what’s happening:
It is not letting me go to the next problem the code is executing but it keep’s doing the same problem as everyone else, tried refreshing page still doesn’t work weird?

Your code so far


<style type='text/sass'>
    @for $j from 1 through 6 {
     .text-#{$j} {font-size: 10px*$j;}
  }
  
  
</style>

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>

Your browser information:

User Agent is: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36.

Link to the challenge:
https://learn.freecodecamp.org/front-end-libraries/sass/use-for-to-create-a-sass-loop/


#2

Not sure. I can copy/paste your solution and it works fine. Have you tried ctrl+refresh or clearing cache/cookies/etc?


#3

Are you by any chance using Edge, IE, or Safari as your browser? Free Code Camp has bee updated to use newer technologies. It makes the application much faster and it means that we can go much longer without having to do a huge migration like the recent one. However, Edge, Internet Explorer, and Safari are very bad about choosing not to adhere to standards and support new functionality in JS and CSS. Right now, that means that these browsers exhibit lots of unexpected behavior. If you become a web developer you will come to hate these browsers with every fiber of your being.


#4

Nope, just Chrome like I said the problem kind of run’s weird.


#5

Try resetting the challenge and pasting your solution in again. Sometimes the tests can get themselves in a hung state by trying to run when the solution the wrong sort of wrong and because it’s hung, it can’t retest when the user has the correct code.