Using CodeSandbox with the MongoDB section

I tried to use glitch to import the github repo, but it wouldn’t work (it imported no files). So then I tried with codesandbox and it imported, but fcc wouldn’t like it. I pasted the link in (https://px9zo.sse.codesandbox.io/) and none of the tests passed. The project link is here: https://codesandbox.io/s/fcc-mongo-mongoose-challenges-px9zo

Also, I like codesandbox better. Any ideas?

Thanks in advance.

@Steffan153 Not sure if this will solve the Glitch issue, but you must be already logged into Glitch before clicking the link.

Sorry, didn’t fix it. I actually didn’t have an account, but just made one. Also, it actually does import one thing: the README.md file. Only one thing.

Thanks, but my question was actually how to use codesandbox with it?

I know your question was not about how it would work on glitch, but you need to sign into glitch with your GitHub account. Then click the link and it works. I struggled with this because I signed into glitch with an email address and it didn’t work. I got help from someone, I logged out of glitch, then logged back in with GitHub and it worked. Just posting incase someone else having the same problems comes across this.

Found the problem, I might open a pull request on that repo:
this line:

app.use("/_api", enableCORS, router);

For some reason, freeCodeCamp sends it with an extra slash at the beginning. So this line needs added afterwards:

app.use("//_api", enableCORS, router);

Fixed it for me.

I did exactly that. :wink: But, I got it working on codesandbox so I’m good :slight_smile:

@freeCodeCamp made a fix on this pull request: https://github.com/freeCodeCamp/boilerplate-mongomongoose/pulls