Weather app and geolocation not working after a certain hour (SOLVED)

Weather app and geolocation not working after a certain hour (SOLVED)
0

#1

Hi!
I noticed that neither html geolocation nor the weather apps I’ve seen are working after a certain hour. In my case is 8 PM. Is that a local issue or it has to do with too much requests? Is there any JavaScript coding solution for this?
Thank you.
SOLVED: Firefox issue. In about:config at geo.wifi.uri I changed the Google API key with https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%.


#2

i just check my app and everything works fine

i might need extra information related to this problem
-You said it stop working at 8 PM. Does it happen everyday?
-Have you try another method like this for geolocation & this for weather apps

This problem also occurs when i do the project. I have solution to do whenever this problem occurs, it might sound stupid but it works most of the time. I clear cache from last hour, turn off my laptop and modem, take the battery. Put it back in. Turn it on. And voila… it works again


#3

Hi!
Yes, this is a daily issue. What I use for my challenge app is HTML geolocation + https://fcc-weather-api.glitch.me/api/current?.
What happens is that after 8 PM HTML geolocation stops working and also the FCC weather api. First I thought I did something to mess my code but when I go to w3school link and press the try it button it doesn’t display the coordinates after I allow location access. Also I can not retrieve data from the API, I can see that in my console. The problem is when I go to others codepen users apps: they don’t work either, most of them show a loading message.
I use Ubuntu, Firefox and codepen.
The issue must be either on OS, browser, editor or due to the fact that I access the API too many times (practically, every time I save my work). But I don’t know where.
I tried cleaning the cache, no result. I will try to see if is working on mobile devices and the restart solution today.


#4

so many factor to check. I’d say to follow it’s behavior and learn anything else after 8 PM.

If you still curious, here is what you can do :
-use another browser
-use another laptop/OS
-use another hotspot
-use incognito mode
-change your time manually

that way, you can find which factor cause this problem


#5

It works in Chrome now and is actually more accurate! The example app also works but there are some apps that don’t, one even gives me the weather from my home town. :))
I will play with Firefox settings to see what is wrong.
Thank you.


#6

Are you on a VPN or using a proxy to connect to the internet? Also, do you have a link to your Weather project?


#7

I never know how to answer to this. I am on a WI-FI connection, no proxy appears on settings.
The link to my codepen project:


#8

All seems fine on Chrome and Firefox. The only thing I notice, is that you have an error when trying to load:

https://fonts.googleapis.com/css?family=Arial

Google Fonts error (400): Missing font family


#9

Thank you, I will fix it. I always seem to mess up the fonts part. As for the Firefox issue I think I will choose the eternal easy solution: install/reinstall :slight_smile:. Is very strange though, I remember browsing a few moth ago through the challenges to see what I will have to face and the weather app from the FCC example was showing the right location, now is a bit far from where I really am. Chrome shows it accurately, I guess something happened after the Firefox update from August. I am a bit stubborn with fixing this as I am used to Firefox, I know is a silly habit. Also, the icons in Chrome display differently and I don’t like that.


#10

I managed to fix it!
In about:config at geo.wifi.uri I changed the Google API key with https://location.services.mozilla.com/v1/geolocate?key=%MOZILLA_API_KEY%. It still doesn’t show my accurate location, but it’s working!