Wh is this not working

PS C:\Users\Sali Meholli\Desktop\dojo-blog> npx json-server --watch data/db.json --port 8000
Error: EPERM: operation not permitted, mkdir ‘C:\Users\Sali’
command not found: json-server

I’m assuming it’s because you’ve got a space in the middle of the path. your path:

C:\Users\Sali Meholli\Desktop\dojo-blog
             ↑
           here

Then the json-server package tries to create a directory, but as that directory is at:

C:\Users\Sali

That path doesn’t exist and your computer won’t allow you to create a directory there, hence the error.

Ideally you wouldn’t have spaces in file/folder names, but here we are, and as it’s your user & therefore also your home directory name I assume it will be a pain to change.

I think you will need to enter the full path to whatever it needs to point to because you need to escape the space. I don’t use Windows so I’m not sure how to do that: on my computer I just do Sali\ Meholli but I don’t think that works for Windows. I’m not sure which option that’s passed to json-server needs the path to be specified either: I assume the one to data/db.json, so would need to be

npx json-server --watch 
PS C:\Users\Sali{however you escape this space}Meholli\Desktop\dojo-blog\data\db.json --port 8000