When I click Curriculum it wants me to sign in

I am still able to sign in, but when I go to curriculum it automatically signs me out still.

I see the login page is reverted to the old style with logos, but the curriculum page still does not work.

hello , i have the same loggin issue , when i logged in and go to the courses it just open a new tab and log me out , and when i click on the sign in button it takes me back to the home page to find maself logged in , and my progresse has stoped , HELP !!

I am having this problem. I just use my email. When I click on the curriculum tab, the top right corner which typically shows my avatar instead shows the loading bars for a few seconds, and then shows the sign in button. So I press the sign in button, and a new tab opens which shows the Welcome page for FCC, as if it succesfully signed me in. From there, I click on curriculum and then the same problem persists where it apparently logs me out and the top right corner shows the sign-in button instead of my avatar.

I have tried manually signing out from the settings and signing in with my email and the special code sent to my email. But this has not fixed it.

its happening to me as well,
i sign in but every time i click somewhere it signs out and asking for me to sign in again

Here is the fix for anyone facing the issue:

  1. Open learn.freecodecamp.org in one tab.

  2. Open www.freecodecamp.org in another tab.

  3. Open the Developer tools for both the sites, here is how you can do it for your browser.

  4. Clear site data for both.

    Here is how you can do it on Chrome:

  5. Login again and you should be able to signin on both applications.

We are working on a fix that will be rolled out in a few hours. Our sincerest apologies, this is a side-effect of the rollout of the new version of freeCodeCamp.

If the above does not work:

Please use an incognito window and sign in to continue working, we will have out new platform rolled out soon. Thanks for your patience.

1 Like

I am now able to reproduce the problem in Firefox 69.0.3, logging in via GitHub
Steps to reproduce:

  1. Log out of freeCodeCamp from the Settings page
  2. Clear Session Storage, Local Storage, Cookies for freecodecamp.org and learn.freecodecamp.org
  3. Log in via GitHub (Observation: my avatar appears in the top bar)
  4. Click curriculum (Observation: I see a “Sign In” button in the top bar)
  5. Click “Sign In” - A new tab opens to the Welcome Page. I am logged in.
  6. Steps 4 and 5 can repeat infinitely.
  7. Inspect browser storage:

Yes, I figured out the issue. My bad, and a real oversight.

I have left a comment as a work around. This will be resolved real quick in a few hours. We are working to rollout the new platform as we speak.

Thanks for reporting.

2 Likes

Still no luck here. Tried logging out and back in.
Edit: Just saw your last post. Thanks!

Has anyone encountered this?

Essentially what is happening is: I land on the welcome page of FCC, i click sign in and I am signed in to my profile. However, whenever i click curriculum, it signs me out and takes me to the curriculum page.

This is easy to spot for me as i have the night background for my profile but when i hit curriculum it changes to the bright background.

I have exited the browser a couple times and there is no fix. I am using google chrome. never encountered this before

The clear data workaround is not working for me in Firefox or Chrome. Same behavior as before.

The clear data workaround has not worked for me either on Chrome.

clear data doesnt work…

2 Likes

The easiest way for now would be to use a incognito window. Our sincerest apologies. We will have rolled out the new platform soon in a few hours to resolve this. Thank you for your patience.

1 Like

I hear you that you’re rolling out the new platform, but maybe just take the site down then…? Incognito window is not working either.

1 Like

You can still access and use the site. Simply save your solutions outside of freeCodeCamp for the next few hours.

1 Like

Ok, makes sense. Looking forward to the new site.

If clearing data does not work:

Hello FCC.
When I click on my portfolio, I see the number of coding challenges done but when I start exercice, I’m not logged and in my curriculum too. Is someone have the same issue ? Regards.

but will my solutions be saved?