Why solutions are not working?

Tell us what’s happening:
Describe your issue in detail here.

  **Your code so far**

<style type='text/scss'>

@for $j from 1 through 5{
.text-#{$j}{font-size: 15px * $j;}
}

</style>

<p class="text-1">Hello</p>
<p class="text-2">Hello</p>
<p class="text-3">Hello</p>
<p class="text-4">Hello</p>
<p class="text-5">Hello</p>
  **Your browser information:**

User Agent is: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:96.0) Gecko/20100101 Firefox/96.0

Challenge: Use @for to Create a Sass Loop

Link to the challenge:

It looks like you have the same issue as the last challenge.

The code you have shared works on my end. Please ensure that you have disabled any extensions that interface with the freeCodeCamp website (such as Dark Mode and Ad Blocker), and set your browser zoom level to 100%. Both of these factors can cause tests to fail erroneously.

Thank you jwilkins. But all the extensions are disabled on my end and zoom is also at 100% . For rechecking I even enabled the troubleshoot mode on firefox but the solution still doesn’t work while in the local code editor sass code is correctly compiled to .css code. I am facing the same issue in previous 2 challenges starting from solution number 5 onwards, once I tried signing out and removing cookies as well but it didn’t work at my end.

Have you tried other browsers?

I am using chrome and it passes for me.

Your code passes for me in Chrome but not in Firefox. My guess is there is a bug with the test suite related to Firefox. I think you’ll need to use a Chrome-based browser.

2 Likes

I tested it again on both chrome and safari and it works for both of those browsers.
The test isn’t working on firefox for me though.

There have also been other challenges where firefox has been an issue.

You could open an issue on GitHub

Bugs can be reported as GitHub Issues. Whenever reporting a bug, please check first that there isn’t already an issue for it and provide as much detail as possible.

1 Like

Yes, it works on chrome. I always do these challenges on firefox but only this time I will have to use it on chrome :frowning_face: Anyways, the problem didn’t occur for solutions from 1 to 4 but from challenge 5 and onwards, this issue started persisting, and I also once found an error like c file is not imported in test error etc. yes there’s probably some issue from backend.

It looks like there was already an issue brought up on github

Yes, I hope this problem gets resolved soon.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.