Worldcup Database - Test Runner failed

I created database and scripts for the worldcup database from the relational database course.

It seems like the test fails in general as I don’t get a specific error message but a generic “Test Runner failed”.
I tried dropping the database and building it again and also tried resetting the course without success.

Database dump and scripts can be found here: freeCodeCamp_submission/worldcup at main · kaiser12796/freeCodeCamp_submission · GitHub

In case I don’t miss any mistakes I would be ready to submit my solution but can’t complete the project with above issue.

Thanks for any help in advance!

By chance, are all your third-party cookies enabled?
Try clearing your cache and cookies if you haven’t.

Did you get it figured out @janguenther1? Using your three files, the tests all passed for me.

@kwame.arms good thinking but didn’t help unfortunately. I cleared cache and cookies and double checked that 3rd party cookies are enabled with no change in test behavior.
@moT01 Any other ideas? In the meantime I just keep going with the other courses

I don’t think you are having issue running the container - so it shouldn’t be any issues around cache/cookies/etc.

It’s possible something got messed up in the VM - maybe you accidentally deleted a key file or who knows - sometimes they just kind of break. One way that should work is to use the last resort option here to delete your container on the CodeAlly dashboard. Then open the project again on freeCodeCamp, it will create a new container for you - since you have all the files saved, just copy them into the container → rebuild the database using the command in the instructions → add executable permissions to the scripts → run the tests - I think you need to run your insert_data script manually, as well.

That did it! Thank you.
Didn’t have to run the insert_data script manually, inserts were part of the dump already.

How do you delete the container.?
please