Would someone please check my portfolio site

I just finished my final project and redesigned my portfolio site. After checking everything on my computer, I reuploaded my HTML, CSS, JS and images to A2 web hosting. It was messed up but I figured it was a caching issue. I viewed it in incognito mode (Chrome) and it was still messed up. I created new CSS and JS files with a “3” at the end of my file names and my Details was only good in incognito, the main page was still messed up. However, it looks fine in Firefox. I did CTRL+F5 for a hard refresh but maybe I need to go into settings.

Would someone check it out and get back to me with your results:

  1. Main page: James Kernicky Portfolio - that should show a nav bar and animation of an image in the header/hero area. That was all missing and it showed only an old project card image - all other project info was missing.
  2. The Details page for the project: James Kernicky Project Details - that is a brand new page and so that is why I think this is a caching issue. Oops, looks like I never changed the page title for that one.

Thanks for your help!!!

1 Like

I am new around here and I clicked to link to your page and it worked from my phone. I only checked the tarp app and the calculator worked well. I like the aesthetic of your site. Hope this feedback helps.

Page looks good on cell. I suggest you go to the hosting server and do a cache flush there. (Sorry not sure how as I use Wordpress on the site I own and I know there is an option to flush the cache from Wordpress but I cannot advise how to do it from other systems). You can also try to go into the settings on chrome and clear all history.

As long as you saw the nav and animated image then I guess it’s a cache issue on my end - thanks!

Ok, thanks. I’ll just clear my cookies and history and that should do it on my end.

Actually I just checked on chrome on a laptop and it is not working there. Sorry to say.

Really? I went back and changed my JS and CSS file names to the original file names. Is this what you see:

Because that’s what I’m seeing today and the same from yesterday. It’s either caching or my host A2. Should I create totally new file names for the CSS and JS?

You know what? I’m also on Cloudflare. Do you think I may need to clear the cache there? The pages and files in question here are alongside my WordPress install, so they are not being influenced by my WP caching plugin but maybe Cloudflare is not up to date. What do you think? Let me look into A2’s cache flush and Cloudflare. Thoughts?

Yes on chrome the image is the same as your screenshot.

How about now? I cleared the cache on Cloudflare, went to the page - same image, then did CTRL+F5 and it’s back. Good for you too now?

Tbh I don’t know. If it was me, I would move all the code into a temp directory, then just focus on getting one file out at a time to the public directory. Like just have the html by itself and make sure all the content is showing up as expected (without any css or JavaScript). Then add the css. Confirm it is working as expected. If you can get that far then you know it is the JavaScript and you may want to comment out most of it to see what may be happening with it. (Allow small scripts to run at the start so you can try to narrow things down). But I am not a web dev so there may be a less tedious way to debug. If you cannot get your html and css to work as expected then you know you have a issue there. Etc.

i’m not sure. On the phone it looks completely different than on my laptop browser.
On my laptop it shows the image you posted earlier… Is that how you wanted to look?

I’m on my laptop and it’s back to normal for me after clearing my cache on Cloudflare and doing a hard refresh. Did you try CTRL+F5 on your laptop? Cloudflare served up the old cached files. Once I manually cleared it the page was fine, but you still have the old Cloudflare files in your cache.

yes it is showing up properly now. I’m afraid I can’t review as I’ve spent too much time on this already. You may want to post another topic to get reviews now that it is working.

No problem, thanks for the update. I wouldn’t have thought about Cloudflare if you hadn’t replied that there was a problem - I think the issue is resolved - you rock!

1 Like