Your h2 element should be red. But this is already red!

Hi. The demand “Your h2 element should be red.” doesn’t satisfied but h2 is actually red! How can I answer else in this task?

The previous task doesn’t satisfied if you write curve brashes in several lines, though in the screen of the theory the code example uses several lines for curve brashes:

<style>
h2 {
  color: red;
}
</style>

I’ve tried to use one line in this task but nothing, RGB have tried too.


<style>
.red-text {
  color: red;
  }
</style>

<h2 class="red-text">CatPhotoApp</h2>
<main>
<p>Click here to view more <a href="#">cat photos</a>.</p>

<a href="#"><img src="https://bit.ly/fcc-relaxing-cat" alt="A cute orange cat lying on its back."></a>

<div>
  <p>Things cats love:</p>
  <ul>
    <li>cat nip</li>
    <li>laser pointers</li>
    <li>lasagna</li>
  </ul>
  <p>Top 3 things cats hate:</p>
  <ol>
    <li>flea treatment</li>
    <li>thunder</li>
    <li>other cats</li>
  </ol>
</div>

<form action="/submit-cat-photo">
  <label><input type="radio" name="indoor-outdoor" checked> Indoor</label>
  <label><input type="radio" name="indoor-outdoor"> Outdoor</label><br>
  <label><input type="checkbox" name="personality" checked> Loving</label>
  <label><input type="checkbox" name="personality"> Lazy</label>
  <label><input type="checkbox" name="personality"> Energetic</label><br>
  <input type="text" placeholder="cat photo URL" required>
  <button type="submit">Submit</button>
</form>
</main>

Your browser information:

User Agent is: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.138 Safari/537.36.

Challenge: Use a CSS Class to Style an Element

Link to the challenge:

  • Your code works fine for me. It seems like the problem might be your browser’s extensions that have access to the FCC site. It looks like you have dark mode that makes the red a little darker than usual. So the FCC Tester won’t see it as the same rgb.
    Try disabling some extensions. If the problem still persists, you can try to use a different browser.
1 Like

switch off the dark mode extension, you can use the native dark mode extension (in the settings it can be switched on)

1 Like

As @ieahleen said, FCC already have its own dark mode you can find here:

1 Like

I’ve just turned off an extension with this access to the FCC and everything works! Thank you!