ES6: Declare a Read-Only Variable with the const Keyword

I am still getting this error, why isn’t it fixed yet ??

Not just me being a numpty then :slight_smile:

Also happening to me too, I wonder if anyone has actually passed this section!?

This is the only thing I can’t pass to get my cert!?! FRUSTRATING!!!

I can’t get my certificate for Responsive Website either. I think they say that you only need to finish those projects for 100%.

The same error happened on mine.

Actually, I was able to claim my cert, even though I didn’t complete this one challenge. But I’d still like to pass it eventually, though, so this section is 100% complete.

BTW - heads-up: I’m attempting the SASS section for the next cert and it’s VERY BUGGY!?!

thomlom’s PR was approved and merged 3 days ago and its still bugged on live site :frowning: this is not good for those with OCD

This has been fixed.
Try going into settings, and claim it again.
If that doesn’t work, try submitting one of the project links again and then try claiming it.
Hope this helps :slight_smile:

The error persists with me. I’m going to try to jump to the next lesson…

Evidently, someone tried to fix this, but now there is a different error (and it STILL won’t pass)!?!

My code:

function printManyTimes(str) {
  "use strict";
  // change code below this line
  const SENTENCE = str + " is cool!";
  for(let i = 0; i < str.length; i+=2) {
    console.log(SENTENCE);
  }
  // change code above this line
}
printManyTimes("freeCodeCamp");

Results in:

// running test
invalid regular expression flag s
// tests completed

Now… Ugh!?! Lol…

I stated the bug in detail, also tagged @QuincyLarson. Don’t know shall I submit it somewhere else too?!

Check this link for detailed bug. I think it maybe possible to have some hacky tricky way to bypass the bug for now.

The bug is about a typo, related to regex

The link with detailed bug info

Did you make the comment on the github site?

Thanks for helping dear Randell.

I’m so sorry, I was looking for repository url actually, that just found it with, going to open an issue.

Thanks.

The issue has already been opened.

Yes got it, seems great people got it already with one I got today too. Perfect.

Thanks for sharing the issue track link, I was looking for github path.

Settings worked for me! Thanks for the tip!

1 Like

Did you passed the test ??? I am still stuck in this one. Please tell me how you fixed the problem