Learn Bash Scripting by Building Five Programs

Please don’t post pictures of code. Just paste the code with markdown.

Also, provide a link to the challenge.

Okay, thankyou for letting me know!

That looks correct @mayojo. You could try running the tests again. The only thing I see that could be causing this code to fail is that the $ sign looks a little italicized or something. It looks completely vertical in my VM - perhaps that’s some other $ character? FYI - The intent is to have you just type into that file, not add the code to the file from the command line like that.

1 Like

Just out of curiosity, why don’t we want pictures here @kevinSmith? They can be particularly helpful with these lessons. There’s no direct link to these challenges, so users can’t provide that - and they don’t even really have titles. So, in order to determine what step someone might be stuck on and what might be going wrong - it’s nice to see the instructions, and what the error message is, and as much as possible really.

It’s always been put that way. Besides the bandwidth, if someone posts the actual code, we can cut and paste and work with it rather than having to retype it. It is a short amount of code here, but most of the time it isn’t. There are situations where an image conveys something that code and an explanation won’t - then an image makes sense. Usually that isn’t the case. I don’t think it was here.

There’s no direct link to these challenges, so users can’t provide that - and they don’t even really have titles.

Well, there should be something, even repro steps. I haven’t looked at these challenges. I didn’t even know they existed or how to find them, set them up.

Give em a try @kevinSmith :wink: Here’s how

OK, part of the DB stuff. I didn’t even know that. I’ll get around to that eventually.

1 Like

Thankyou. I’m trying to run the tests again now.

I have seen people asking questions with pictures for RDBMS so, I uploaded. I do think it is the case here.

OK, I’m not trying to make a big stink here. We’ll see how it goes. I (and I assume others) avoid pic problems because we don’t want to retype things to try them out.

1 Like

Hello, I reset the tutorial it was still not working and I went to CodeAlly dashboard and deleted the container. It is working now. Thankyou!!

1 Like

Hi quick question, I’ve tried everything from running it locally, restarting the vm, changing the remote container. :upside_down_face:
But I can’t seem to move on from either step 2 or 3 from this tutorial.

It always prompts me the wrong solution and I can’t seem to find a way to fix it, any help would be much appreciated thx!! :smiley:

make a file manually rather than using a command see if that helps.

When the test text doesn’t align with the instructions, the problem is like similar to the one described in this thread. The solution there may help. I’m in the process of restructuring some of the tutorials to hopefully fix this type of issue.

1 Like

It didn’t help but it might just be me, since this is a work in progress and I really liked what I learned from bash, could you point me to any resources on bash scripting that would be ad-hoc to the upcoming lessons?? thx again for all your help :blush:

If all else fails, you can delete your container and start over

As a last resort, you can go to your CodeAlly dashboard and delete the container with the name of the tutorial that is problematic. Unfortunately, you will have to start the tutorial from the beginning if you do this. Note: the dashboard may not update until you refresh the page.

This is from the form. I faced the same problem and tried this. It woked out. Hope it workds out for you too!

1 Like

Just to let you know, it was a complete mistake on my part. I used other resources for scripting in freecodecamp, and when I got back to the tutorial, I’ve realized I’d never inserted the echo hello questionnaire on the file. :upside_down_face:

1 Like

Can anyone please help me , while placing shebang . The absolute path comes to /usr/bin/bash.

So i have entered the below commands

bash questionnarie.sh

So what exactly needs to be done here , I am unable to move forward and understand the concept here ?
Please help .

@moT01 , I just fired up this one and have been spending a lot of time Googling how to make all these edits from the command line i.e. inserting text at certain lines…


I realized that maybe the intent was just to type it straight into the file and came here to see if anyone else had encountered same thing…It may be worth adding to the instructions as it wasn’t super clear.

I’m working on “Build Five Programs” but can’t seem to get past the CodeAlly “Redirecting back to origin site” step. I haven’t had any problems with the first three courses. Any ideas how to get past this?