Running the Relational Database Curriculum in your Browser

What did you do exactly on test 670?

I managed to get my self to the test folder but can’t understand what’s wrong :stuck_out_tongue:

Nvm I just deleted everything besides 690 and the other non test files and it worked as well :stuck_out_tongue:

1 Like

Did you get this resolved @charss? There’s some troubleshooting steps above that may help. I would try refreshing the page - if your progress is saved, you will see a checkmark next to ‘Step 1’, which will allow you to submit the URL and finish step 2.

Edit: There’s a comment here that can maybe help you with your repo.

1 Like

My Editor is not displaying in World Cup database.
here is what it shows and i am out of clue i tried refreshing but doesn’t worked.

1 Like

Unfortunately it still doesn’t count the project as completed. I also followed the troubleshooting steps (deleted and worked on the project from scratch AGAIN) but still no luck.

Seems like a little bit of a fluke @dhairya221b - it looks something went wrong trying to load the container. The troubleshooting steps above tell you how to delete the container. I would try to do that and start again.


There’s a chance your user token was deleted @charss. When you sign out, we delete your user token as a security measure, so someone else can’t submit your projects. Did you sign out of your freeCodeCamp account at all? A new token is created again when you open up one of the projects, but existing VM’s still have the old token until it shuts itself down. I’m not sure if that’s the issue, but here’s what you can try - open up a different project, any one - that will shut down your running celestial bodies project. Then go open the celestial bodies back up, the container should now have your new token - and, if you finished the project, it should take you right to the last screen. Press that continue button to submit the project again. If this is the issue, it should now be saved and show up the next time you refresh your freeCodeCamp page.


That did the trick!! Thank you very much and more power to you.

1 Like

I ran into an issue with one challenge on the learn bash by building a boilerplate project. When you are in the freeCodeCamp folder and it asks you to use the more command with the package.json file in the terminal. It would say “more 61%” and then it wouldn’t do anything else. Anyhow I found that using ctrl + c on the keyboard unfroze the terminal so the challenge would pass.

@LeiCorre That’s not a bug that’s how the more command works in bash, it displays part of the content of the file (if the file is more than X lines long, where X is a number you should google cause I dont know :stuck_out_tongue: but it must be a function of how big your terminal window is )

In order to proceed you should press enter untill it reaches 100% (so until it shows you the rest of the lines while the previous lines dont fit anymore in your terminal screen and you should scroll up in order to see them) and then you would also see the prompt again and be able to enter new commands.

I can not run psql… I already check the status of psql server, stop, restart… but always get same error… any ideas ?

Try hitting that reset button and resetting the step.

Did you delete any files or anything? The theme isn’t being applied.

Hi, I already try with reset button… and still and the same step.
I did not delete any file…

This is my history

codeally@f84c772e401d:~$ history
    1  psql --username=freecodecamp dbname=mario_database
    2  pwd
    3  psql
    4  echo hello postgresql
    5  cks
    6  cls
    7  clear
    8  pwd
    9  ls -l
   10  cd learn-relational-databases-by-building-a-mario-database/
   11  dir
   12  clear
   13  ls -l
   14  cat tutorial.json 
   15  clear
   16  psql
   17  psql --username=freecodecamp dbname=postgres
   18  psql start
   19  sudo service psql
   20  clear
   21  sudo service postgresql status
   22  sudo service postgresql start
   23  psql --username=freecodecamp dbname=mario_database
   24  psql
   25  cd ..
   26  psql
   27  clear
   28  psql --username=freecodecamp dbname=mario_database
   29  psql
   30  clear
   31  sudo psql
   32  sudo
   33  clear
   34  who am i 
   35  clear
   36  sudo service psql status
   37  clear
   38  sudo service postgresql status
   39  psql --username=freecodecamp dbname=mario_database
   40  psql
   41  clear
   42  psql
   43  ckear
   44  clear
   45  pwd
   46  ls -l
   47  sudo service postgresql restart
   48  psql
   49  exit
   50  psql
   51  sudo shutdown now
   52  exit
   53  psql
   54  sudo service psql status
   55  sudo service postgresql status
   56  sudo service postgresql restart
   57  ls -l
   58  cd learn-relational-databases-by-building-a-mario-database/
   59  ls -l
   60  cat codeAlly.json 
   61  cd ..
   62  ls -l
   63  ls a-l
   64  ls -al
   65  cd .freeCodeCamp/
   66  ls -l
   67  cd
   68  pwd
   69  psql
   70  psql --username=freecodecamp dbname=mario_database
   71  sudo service postgresql status
   72  psql --username=freecodecamp dbname=mario_database
   73  sudo service postgresql status
   74  ..freeCodeCamp/
   75  ./.freeCodeCamp/
   76  clear
   77  cd .
   78  dir
   79  cd ..
   80  ls -l
   81  ls -al
   82  cat .profile
   83  clear
   84  ls -l
   85  cd project/
   86  ls -la
   87  cd .freeCodeCamp/
   88  ls -l
   89  clear
   90  ls a-l
   91  ls -al
   92  clear
   93  ls 
   94  ls
   95  ls -l
   96  cd ..
   97  ls -l
   98  cd .freeCodeCamp/
   99  npm install
  100  find --name
  101  find -
  102  find
  103  cd ..
  104  clear
  105  find -name
  106  locate
  107  sudo apt-get install locate
  108  clear
  109  locate
  110  sudo updatedb
  111  locate
  112  locate pg.log
  113  find pg.log
  114  fing -name pg.log
  115  find -name pg.log
  116  cd ..
  117  ls -l
  118  clear
  119  ls -al
  120  cd ..
  121  dir
  122  clear
  123  ls -l
  124  cd codeally
  125  ls
  126  cd ..
  127  cd guest
  128  ls -l
  129  ls -al
  130  cd ..
  131  ls -al
  132  clear
  133  psql --username=freecodecamp dbname=postgres
  134  ls -l
  135  cd
  136  clear
  137  ls -la
  138  cat .bash_history 
  139  clear
  140  ls -al
  141  cd .config
  142  ls -l
  143  clear
  144  ls a-l
  145  ls -al
  146  cd code-server/
  147  ls -la
  148  cat config.yaml 
  149  su
  150  clear
  151  pwd
  152  su codeally
  153  clear
  154  ls -l
  155  cat config.yaml 
  156  su codeally
  157  cd ..
  158  ls -l
  159  cd configstore/
  160  ls 
  161  clear
  162  ls -la
  163  cat update-notifier-npm.json 
  164  cd ..
  165  ls -l
  166  cd ..
  167  ls -l
  168  cd swift-5.3.3-RELEASE-ubuntu20.04/
  169  ls -l
  170  ls -al
  171  cd usr
  172  ls -l
  173  cd local
  174  ls
  175  cd
  176  ls -l
  177  ls -al
  178  cat .gitconfig 
  179  cd .nvm
  180  ls -l
  181  cat | more
  182  clear
  183  ls a-l
  184  ls -al
  186  ./ 
  187  psql
  188  sudo psql
  189  psql
  190  exit
  191  sudo service postgresql status
  192  psql
  193  clear
  194  sudo service postgresql status
  195  sudo service postgresql restart
  196  sudo service postgresql status
  197  psql --username=freecodecamp dbname=mario_database
  198  psql
  199  sudo psql
  200  sudo service postgresql stop
  201  sudo service postgresql restart
  202  sudo service postgresql status
  203  sudo psql
  204  psql
  205  psql --username=freecodecamp dbname=mario_database
  206  clear
  207  history | grep rm
  208  psql
  209  cat history
  210  cat .history
  211  clear
  212  ls -l
  213  ls -al
  214  cd ..
  215  ls -l
  216  ls -al
  217  clear
  218  cat .bash_history 
  219  cat .bash_history | more
  220  clear
  221  psq
  222  psql
  223  history
1 Like

Unfortunately, I think something got messed up in your VM and I think you will have to start over - sorry. You can see the .freeCodeCamp and .vscode folders on the left there - they’re expanded, but they don’t have any files in them. There’s supposed to be files in there for running the tutorial. I’m not sure what caused it, but the files are gone - and I don’t think there’s a way to get them back at the moment.

There’s instructions how to start over above.

I am facing some problem in Mario database. Maybe I got disconnected or something in the middle. I restarted everything but still getting the “Test Runner Failed” error whenever I try to run the test.

getting this image as error.

guys please help because I can’t figure it out, I was resuming my celestial bodies course and when I try to run: psql --username=freecodecamp --dbname=postgres .
I get the next error: psql: error: connection to server on socket “/var/run/postgresql/.s.PGSQL.5432” failed: FATAL: Peer authentication failed for user “freecodecamp”. I’ve tried restarting postgresql and I still get the same error. Any tips?

Are you seeing a similar screen as @jorge.chavarriaga’s screen shot above @andrescerchia? (no theme, can see the folders but there’s no files).

Your terminal doesn’t have the theme either @tanjimanim007. So I think something messed up your VM similar to @jorge.chavarriaga’s screen shot above. You may need to start over as well. Sorry. I will contact the VM provider to see if something changed or got updated on their end that may have caused these issues.

1 Like

Yup i got the same, but didn’t see you answered the question before I posted, so I started all over again, thx anyway XD

does anyone know why my terminal seems to have lost a pixel on the edge of each character? I have tried to change the zoom on my web browser but it is always displaying with a missing edge of pixels in the terminal only