Running the Relational Database Curriculum in your Browser

i tried the exact same process in Brave browser.
it worked after my first refresh after the chages in the settings. but something worse happened, my saved project isn’t loading. Whats loading is a project named “SQL something…” under the project directory.
Clearly not the one im working on.
what im working on was the “Build a Celestial…”.
my project wont load even if i start it from the CodeAlly>playground.
Took a lot of browser refresh and restart, but it still won’t load so i closed all browser and kill all the tasks running in the background. then I open the browser again.
luckily, my saved project was back.
i just completed it now manually typing stuff so i wont lose my progress.

what i haven’t tried yet was the shift+insert method.
i’ll try it once i open the terminal again.
i’m now figuring out how to complete the project by saving in a public repository, maybe using github or something. i still don’t know how at the moment and still trying to figure it out myself.

thank you so much. i really appreciate you sharing your time

Thanks for the previous reply, can’t believe it was a typo.
Now I have another question regarding the periodic table challenge, I’m completely lost as to how to go about it, I can do everything it asks (git, edit the database, writing the script). But I’m lost as to how to approach it do I make a sql reference json where I edit the database there and the script too? Or do I edit the database straight from the psql terminal and git init the script. Any help is welcome!

¿Podrías mencionarnos mas sobre el problema y adjuntar una captura de pantalla?
Could you please tell us more about the problem and include a snapshot?

Hi I already completed the Mario Database, but it never gave me the check in the circle on the Relational Database mainpage… I try to get back into CodeAlly and now it’s stuck here as shown below. I tried restarting the coderoad module many times and it still hasn’t come back. Any help would be appreciated.

Any luck @Chrsr? I feel like I would try to close CodeRoad and reopen it until it works. You tried that already. There was a small issue earlier, perhaps that was causing problems and maybe it would work if you gave it another try. If that doesn’t work, you could try opening a different project - that will shut down the mario project, and then go back to the mario project after that. That might work? Kind of guessing there, but it’s something to try. Let us know if you still can’t get it.

Hi,

It still isn’t working, other modules do work, so maybe I’ll try and come back around to it. It is still stuck on the launching screen as I showed above. Not sure what else I can do other than soft resets and opening and closing CodeRoad. I tried on different PCs as well.

I’m not sure what else to try either @Chrsr. I haven’t seen this one before. What we could do is try to figure out what is going wrong. If it’s still happening the next time you open the project up, check what the CodeRoad logs are showing. You can check them like this:

Click the output button next to the terminal, and the select CodeRoad (logs) from the dropdown on the right. Share what’s in the output. It might tell us what the problem is.

Hello everyone, I started this course and everything was going fine but now nothing works anymore. The IDE gets loaded but then I can’t do anything after that. Ps, nothing happens when I click the hamburger : (, would be nice if I can get some help I’m currently on the second module.

That’s strange @ayomideowolana1 - how far into that second module were you?

You could try shutting down the project (container) - that may get it working again. Just open a different project, that will shut your running project down, then go back to the one that was stuck to start it again.

Hi here is the output log:

I tried it in a different browser and it works okay now so I guess maybe its cos of my chrome settings. I need help getting back into the database course “Mario DB” I can’t remember what we’re to use as the username. psql username="" dbname="";

The login command should be the last hint in each step @ayomideowolana1. It’s psql --username=freecodecamp dbname=second_database

FOR ANYONE GETTING A WHITE SCREEN EVEN WITH 3RD PARTY COOKIES ENABLED what worked for me was right clicking on the white screen, and selecting “reload frame” Good luck!

1 Like

Hi, I’m doing the Learn Relational Databases by Building a Mario Database module and my first task is to type

\l

Unfortunately, my regular key combination for the backslash on my German MacBook Air keyboard doesn’t work: [alt]+[shift]+[7]
It works when I write text on my Mac but not on the virtual server. I also can’t paste a backslash into the virtual server. What can I do?