Advanced Node and Express - Implementation of Social Authentication Github refused to connect

Hello, I’m currently learning github authentication section. I pass all the test but when I try to login to github, it keep saying “Github.com refused to connect”. I try to copy everything from the example but still not work. So, maybe my .env file or the way I set my github strategy is wrong but still I can’t figure it out. Here’s my link https://repl.it/@IndraSubagja/boilerplate-advancednode#.env

Hello there,

As it should be, we cannot see your .env file nor contents. So, unless you are wanting to deal with the risk associated with sharing private keys, I suggest you debug this slowly by going through the lessons again, ensuring to do everything correctly.

@Sky020 Nevermind. I solved it all. Damn, I won’t force my self when I’m so sleepy next time :laughing:. Thanks

1 Like

Hi @IndraSubagja , I’m having the same issue and clearly blind to my own mistake. Would you mind sharing which area/ file you looked into and fixed for this? Thanks in advance

@zepluzowo Well, if you use repl.io and have tried to copy everything but still encounter that problem, then it’s simple. Just open your site separate from repl.io (not directly in repl). Hope it helps :slight_smile:

@IndraSubagja whoa, I can’t believe that was the issue the whole time. I was just endlessly clicking the link directly in repl.io and wonder why Github is rejecting me. Thank you for saving me and my mouse :laughing: :laughing: