Apis and Microservices Projects- down?

Is the Apis and Microservices Projects portion down? I haven’t even finished the code to complete the challenge for the Timestamp project, and submitted my Glitch link, and it passed.

To test my theory, I randomly entered another glitch project that I was working on into the spaces for both Glitch and GitHub input, and it passed.

I then tried entering the same project link for the next challenge, and it also passed.

Are there actual tests in these challenges to check your code?

Hi @sidneyyin, i am having the opposite problem were i cant pass the first challenge.


Yeah… I just checked it again today. Just for another test, I submitted the same project URL on glitch to both the glitch form input and the github input (Why do we need both, I thought it was one or the other?). And I even submitted it to FCC to receive the certificate for API section, and I got it. Without having actually completed any of the projects.


You agreed to an academic honesty pledge, you are violating it by claiming certificates for which you didn’t work for

I know that. I have no intention of passing challenges without properly doing the code myself, hence my initial post. I am merely making an inquiry about why these challenges are all passing despite incorrect code. I am trying to learn! Thanks. @QuincyLarson – or another support team member – help?!

Thanks for the additional detail. Could you tell us which specific challenge you are attempting to get pass? You’re saying that even if your project shouldn’t pass the test (missing an API endpoint that you haven’t built yet, etc.) the tests are still passing?

Every challenge in the API section. I recorded a screencast of mine on the Timestamp Service challenge to show you. I’ve even done a private browser in case cookies was the issue:

In my video, I show that server.js is an empty file and yet the challenge passes.

I’ve also tried it in Safari (I was using chrome) separately, and still the same. Is it only on my Free Code Camp account, perhaps? I have every intention of getting the codes right, so if you would like to help me reset that module, only for the API/microservice challenges, I am happy to oblige and try again!

My approach to learning has always been trial and error, which is why I was surprised when I built half the code, to click on submit to see what happens, it was passing.

Thank you much!


i am also having same problem where i cant pass any challenges(in mongo db and mongoose section).
i tried different solutions from forum but timeout has occurred keeps showing up.

@QuincyLarson Sorry to bug you… any updates? I tried again today (even changed browsers to Safari) and all my challenges pass though my code is definitely incomplete.

Wanted to circle back and see if there were any ideas on why my codes are passing (and how I can reset my API section on FCC)?

Thank you!

1 Like

i have somewhat different problem.i can’t particularly pass this challenge https://learn.freecodecamp.org/apis-and-microservices/mongodb-and-mongoose/create-and-save-a-record-of-a-model. i tried many different solutions from forum as well but nothing seems to work and i still get timeout has occurred error.

This may be caused by an infinite loop in your code editor. Here’s how to fix this.

Thanks Quincy. Where do I add this code? On Server.js?
I am trying to follow the instructions on how to disable the infinite loop protect, but not sure where I can even find the"over the line the loop protection message lists".

For reference, I am still trying to complete the first challenge:

I have forked the Glitch link but can’t find where the loop protection message code would be…

Thank you but i am still getting the same error. It is not showing any error in glitch and works fine if i open the live app link in new tab.