Back End Development and APIs Projects - Exercise Tracker

Hello,
I am not able to understand why I am not able to pass the last test, I have been trying to figure it out for the previous two days. I have tried to run it on so many scenarios, but locally it’s working fine.

Can anyone help me in figuring it out??

project link(s)

solution: boilerplate-project-exercisetracker - Nix (beta) Repl - Replit

Your browser information:

User Agent is: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/104.0.0.0 Safari/537.36

Challenge: Back End Development and APIs Projects - Exercise Tracker

Link to the challenge:

I just forked and tested it and it passed. If it’s not passing for you, what errors are you seeing in the browser and console logs?

It was showing test timed out, but now I deployed it on heroku after seeing a similar issue on a freecodecamp forum thread, and there the person’s issue solved after deploying the app on some platform other than repilit. And using the heroku url all the tests were cleared, wierd fix but still finally this worked!!

Thank you for your help!