Back End Development and APIs Projects - Timestamp Microservice - BDK9orzqcuG81SY3nSEGO

I’ve tried to complete this challenge when I noticed Replit couldn’t run. I tried opening a fresh template clicking on the link provided by the challenge and it won’t run even that

Idk what’s going on, maybe the npm need something to be installed. I’m new with this kind of technology so I really have no idea how I can fix this

Replit:
https://replit.com/@HaydenGrey

Challenge:

Can you provide a link to your replit?

sure, idk if this is the link you’re asking for but yeah

https://replit.com/@HaydenGrey

it’s the latest

Updating the npm express seems to now work

that’s all I get when any template of the projects are launched. What does it mean?

Try this:

Go to the Shell tab and type:
npm install

Once packages are installed type:
npm start

Now you should be able to click the Run button and see something in the preview pane (Output). If not, reloading the entire app (Ctrl+F5 in Chrome on Windows or Linux). This should take care of getting the app going now and in the future.

image_2022-07-12_191518262
whenever I try to do either of em I get to select one of these. I selected the first one but doesn’t seem to work

Yes. Select the first one nodejs-16_x.out each time. You might have to do it after each command I mentioned above.

If this still does not work, let me know.

nothing happened. It keep asking to install it over and over again, tried to do “npm start” and the shell just didn’t respond

I opened a fresh template (again) and still nothing. I don’t even know what’s the problem at this point