Basic Node and Express - Use the .env File |||||

Hi, I know everyone seems to get stocked at this challenge . But i am getting really dissappointed becaue I can’t seem to get it ritght. I have modify the code, created an .env file and adjust it as is says… but still coming out wrong . I am not adding link to my project because I have changed it so many times and ive put it just as it says on the forum that .
What are your suggestions ? I am using chrome .

thanks guys.

Challenge: Use the .env File

Link to the challenge:

Do you have any code?

hey , I am just going to re-start it, I left it for couple days .

I’m also having an issue with this challenge. Does anyone have any ideas?
I hope it’s ok for me to share this thread because perhaps we have the same issue! Here’s my Ghost link.

Looks like this is the issue.

You need to update the fCC dependency.

Remove the "fcc-express-bground": "" package from package.json wait for it to be removed, then add it back again to get the latest version.

If I do that your code passes for me.

1 Like

Hey @lasjorg, I appreciate your response. I tried to remove the “fcc-express-bground” dependency, but it isn’t clear to me how to install the latest version.

I viewed the README for this dependency, but it doesn’t provide any documentation for installation.

Naturally the next thing I tried was “npm install fcc-express-bground” but that only resulted in an error. I tried to install this library as well, shortly after I realized this was probably unrelated to my current goal.

Finally, I tried to install the "fcc-express-bground’ dependency manually by entering it into my package.json like so

  "name": "fcc-learn-node-with-express",
  "version": "0.1.0",
  "dependencies": {
    "express": "^4.14.0",
    "body-parser": "^1.15.2",
    "cookie-parser": "^1.4.3",
    "fcc-express-bground": "0.0.5"
  "main": "server.js",
  "scripts": {
    "start": "node server.js"
  "engines": {
    "node": "4.4.5"

Unfortunately, I still haven’t been able to successfully install this dependency. Could you please give me some advice on this? I greatly appreciate your help.

You just add what you removed back again.

"fcc-express-bground": ""

@lasjorg I tried this a couple times, but haven’t had any luck thus far. I’m using Google Chrome.

I’ve tried pasting both this URL to try to pass the tests:

and this one:

Is there anything else I could be missing?

Edit: I’ve also tried clearing the local storage, cookies, and session storage related to FCC but am still stuck with a failing test without any helpful error messages for guidance.

If I remix your project it passes for me.

Maybe try renaming the project or remixing it and submit that instead. BTW, you have to submit the URL without /json

Here is a remixed version (you have to add uppercase back again in .env if you remix it)

1 Like

You were right. Remixing the project (and updating the .env to match the original) was enough to pass the challenge. Thanks a ton! :smile: